Kawasaki Vulcan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Help I have a 2009 Vulcan 900 classic & had been driving it for a couple hours when it died as i rolled to a stop. Had it towed home and have been trying to figure it out every since. Thing is when i turn the key i hear the fuel pump kick on as normal when i hit the starter button it turns over like normal but won't start. I attempted to spray some starter fluid in the filter see if that worked and it started up then immediately died. I changed the spark plugs as well. I am guessing it is something in the fuel system so i have purchased a new fuel pump but have not installed it yet. I also attempted to use a fuel pressure guage but tracking down the converter that works with the Vulcan proved more difficult then i thought. Before i try the new fuel pump i thought i might see what others thought because i have had multiple people tell me that because i can hear the fuel pump engage it is prob not that....but i have also had several people tell me that just because you hear it come on doesn't mean it isn't clogged up. Any feedback would be appreciated:frown
 

·
Registered
Joined
·
507 Posts
...i have had multiple people tell me that because i can hear the fuel pump engage it is prob not that....but i have also had several people tell me that just because you hear it come on doesn't mean it isn't clogged up. Any feedback would be appreciated:frown
I think they're both kinda right, really.

1) Have you run the self-diagnostic?

2) Any unusual behavior from the FI light?

3) You can always do the El Cheapo Home Mechanic (tm) fuel pump test. Pull a fuel line from a convenient location, stick it in a coffee can, switch 'er on and see if she pumps.
 
1 - 2 of 2 Posts
Top