Kawasaki Vulcan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
When I turn the key should the engine temp light flash just like the FI and oil light does?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
75 Posts
Discussion Starter #3
Ok so no way of knowing if it’s working except probing it with a multimeter


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,306 Posts
None of the lights should flash when you turn the ignition on. The oil pressure light will stay steady until the engine starts and the pressure builds up. The FI light comes on (steady) and goes out once the fuel pressure is up. Once the engine is running none of those lights should be on (temp comes on if you're overheating).

Service manual says the FI light will flash if the battery charge is low. I don't know why your other lights would flash. Maybe your ground is bad.
 

·
Registered
Joined
·
11,756 Posts
Fair enough, but I don't see any indication that the FI light will flash under normal operation. The only flashing I see is in dealer modes and low battery charge. Am I missing something there?
Find out if it is actually flashing. Sometimes folks say what they don't mean.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #8
It comes on steady until fi has completed it process. By flash I mean it comes on the. Goes off.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
75 Posts
Discussion Starter #10
In all I just wanted to know if the engine temp light came on during start up to signify that the light works. I’ve already gotten the answer and I’m grateful.


Sent from my iPhone using Tapatalk
 
1 - 10 of 10 Posts
Top