Kawasaki Vulcan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
482 Posts
Discussion Starter #1
Initial diagnosis was reasonable, clutch cable was realky sloppy, then noticed metal shaving on the frame near the back tire, now im freaking
 

·
Registered
Joined
·
482 Posts
Discussion Starter #3
metal shavings? On the frame?

didn't by any chance take a picture, did you?
No picture, but it was between the two little bars going toward the tire
 

·
wocka, wocka, wocka
Joined
·
5,618 Posts
No picture, but it was between the two little bars going toward the tire
Softail swing arm, Rite or left side? Belt side, It mite be drive pulley shredding on the spline? Are you hevy handed with yor throttle?
 

·
Registered
Joined
·
482 Posts
Discussion Starter #5
Softail swing arm, Rite or left side? Belt side, It mite be drive pulley shredding on the spline? Are you hevy handed with yor throttle?
Left side, and yeah a little heavy handed but not too bad, ithink
 

·
Registered
Joined
·
482 Posts
Discussion Starter #6
Got the diagnosis $370 to repair, belt was way to tight, the shaving were from the pulley, trans and clutch were ok
 

·
Registered
Joined
·
3,219 Posts
Did they give you an amount of deflection the belt had on it when you brought it in?

Yes everyone, I am opening that can of worms. I am no mechanic, but I think the factory specs are too tight anyway.
 

·
Registered
Joined
·
482 Posts
Discussion Starter #10
Dont have a clue, he is a good and reliable mechanic im told so trusting his judgement
 
1 - 10 of 10 Posts
Top