Kawasaki Vulcan Forum banner
21 - 25 of 25 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #22 ·
If the pressure is low it could be a restricted secondary filter, if it has one. On the ZX and ZG it can be seen when looking into the hole where the fuel enters that housing. On this pump it would probably be where that rubber seal is, but I don't have a pump at hand to check myself. They can be cleaned with an ultrasonic cleaner, so I have been told. So check the pressure and go from there.
Funny; I didn’t see a screen in there but; I sprayed carb cleaner then used a low pressure air compressor to blow it out. That helped quite a bit but she is still stuttering a little. Two questions: 1. Will it hurt to blow out that housing with higher pressure (44 to 55psi) to blow that dude out? 2. Can the black part on the top be cut off to clean the inside then epoxied back on?
 

·
Registered
Joined
·
27 Posts
So, the part number for the original is 49040-0008, will the 49040-0018 work in the 1600?
Probably. It's about half the price of the -0008 pump from Kaw, but the base plate will probly need to be swapped.

More air pressue shouldn't hurt. Regarding cutting the top off, that should work but if you can wait a week I will cut the top off the scrap pump I have at home (when I get back there) and post a pic of what's in there.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #24 ·
Probably. It's about half the price of the -0008 pump from Kaw, but the base plate will probly need to be swapped.

More air pressue shouldn't hurt. Regarding cutting the top off, that should work but if you can wait a week I will cut the top off the scrap pump I have at home (when I get back there) and post a pic of what's in there.
I would love to see that. In the meantime; I’ve gotten pretty good at pulling the tank and the pump so I’m going to try and clean it one more time like this so I can ride this weekend. Thank you and Happy Thanksgiving ~ M


Sent from my iPhone using Tapatalk
 
21 - 25 of 25 Posts
Top