Kawasaki Vulcan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hey guys, need a little help wiring up the new front turn signals for my 900 classic. The ones I purchased are 12v dual filament with 2 wires (red & black) and the bike's wiring harness has 3 wires.:confused:

I've spent the last hour searching the forum and can't find anything how to wire these new turn signals. Any help would be greatly be appreciated.

Thanks and Happy Holidays,
Snowman
 

·
Registered
Joined
·
546 Posts
I asume the red wire is for the signal filiment and the black is for the running light filiment, you can touch / connect one wire at a time to determine what' what, but before you do anything make sure the turn signal housing is grounded good posibly by the 3rd wire that you mention or the circuit will try grounding it self by the power wire good luck
 

·
Registered
Joined
·
953 Posts
black is normally ground? If it only has two wires then its probaly single filament, look at the actually bulb is there two? If there is it may be a self grounding unit, thats how the kurys ones are,
 

·
Premium Member
Joined
·
1,130 Posts
Sojourner,

They are Emgo, model #61-73190, smooth bullets.

Thanks
The websites that advertise the Emgo don't really come out and say if it's a dual filament or single. They do say it's incandescent, not LED. I'd pop the amber cover off and remove the bulb. If there's a single pin on the bottom of the bulb you know it's single filament. Two pins would indicate dual with the red being one circuit and the black another with the case going to frame ground.
 
1 - 8 of 8 Posts
Top