Kawasaki Vulcan Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
201 Posts
Discussion Starter #1
So I decided to spend some time this weekend putzing on my V2K, mostly
to determine the ins n'outs in a warm shop as opposed to on the side of a road somewhere.
There was some sketchy wiring that I cleaned up, etc. and I was looking to see if the resistor mod was on this bike. While I was in there, I found a couple of pleasant surprises:
First up, as suspected by you guys on the forum, I have an Dynojet PC 3 EFI controller. Looks like I can hook my laptop up and find the mapping which I will do today.
I didn't find the resistor mod as shown in the VN2000 site, but I did find a relay and SpeedoHealer in the tool box. Any ideas?
FYI: I believe this is a US bike (the odo is in miles), and I'm now curious if the Eurogear mod might be installed......I don't have a tach so I can't tell where I am revving at highway speeds yet.......maybe that will be my next purchase.
 

Attachments

·
Registered
Joined
·
220 Posts
I didn't find the resistor mod as shown in the VN2000 site, but I did find a relay and SpeedoHealer in the tool box. Any ideas?
FYI: I believe this is a US bike (the odo is in miles), and I'm now curious if the Eurogear mod might be installed......I don't have a tach so I can't tell where I am revving at highway speeds yet.......maybe that will be my next purchase.
Check the right side of the bike on the rear top of the transmission casing under the electronics compartment and you can see the speedometer sensor. If you cannot see a silver spacer washer between the sensor body and the tranny case where the sensor mounting bolt is, chances are you have euro-gears installed and the spacer was removed for the gear mod so the speedometer will work.
 

·
Premium Member
Joined
·
201 Posts
Discussion Starter #3
Will do. That's be one less addition if I have it (Yay for me!)
Would there be any other reason one might install that speedo healer? The tires are factory size so it's not that......
 

·
Registered
Joined
·
578 Posts
Speedo is off by 10% from the factory, that would be the reason for the speedohealer.
 

·
Premium Member
Joined
·
201 Posts
Discussion Starter #5
Here is what I have, spacer installed. Guess I'll have to physically check to see if I have the Eurogear update..... Manyana.....
 

Attachments

·
Bike Of The Year Winner, 2012
Joined
·
4,906 Posts
If you have the speedo healer (which you do), odds are you don't have the euro-gears.

Also.. check the firmware date on the PCIII. It's probably OLD.

Last year, when I upgraded the firmware on my PCIII that I have had for a decade, I saw an increase in performance.
 

·
Premium Member
Joined
·
201 Posts
Discussion Starter #7
I'll do that. Of course, I'd be hard pressed to know if I have any performance issues. I upgraded from a boulevard C50, so at it's worst it blows the doors off my previous ride........lol
 
1 - 7 of 7 Posts
Top