Kawasaki Vulcan Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I recently purchased as in 2 days ago a 2010 1700 vulcan voyager. I drove it home no issues and then drove it work. All in all about 120 miles. I got to work and it shut down on its own and when I go to start it get the F! and the little red light below oil light just flashes continuously. I get not starter clicks noting just flashing red light and I have zero clue what to do. I do need to get home tonight so any suggestions
 

·
Super Moderator
Joined
·
4,789 Posts
Welcome to the forum from North Carolina. Congratulations on your new ride. If the oil light is flashing, first thing check the oil. When was the last time it was changed and what weight was used. Have to check the bikes for any fault codes that might have been stored. If you bought the bike from a dealer, take it back and have them fix it. If it was a private sale, then it’s all yours. Here is a link to download a factory repair manual showing the procedure to check for codes. Do you have a multi meter and know how to use it? Read up a bit and if anything is unclear, post back and we will help you. Thanks for becoming a member. Be well.

 

·
Registered
Joined
·
105 Posts
What do you mean "I get not starter clicks noting just flashing red light"?
If the bike starts okay, I agree with Tourer and would immediately change the oil and filter. Oil changes are not expensive, but very important. Yet this can be a neglected procedure by some.
 

·
Registered
09 VN900B
Joined
·
211 Posts
I recently purchased as in 2 days ago a 2010 1700 vulcan voyager. I drove it home no issues and then drove it work. All in all about 120 miles. I got to work and it shut down on its own and when I go to start it get the F! and the little red light below oil light just flashes continuously. I get not starter clicks noting just flashing red light and I have zero clue what to do. I do need to get home tonight so any suggestions
Now I don't know about yall but i read this as.
Help I rode my 1700 to work, it shutdown when I got there, now it will not start, Key on I get An FI warning that flashes continuously, starter does not turnover or click like dead battery, not starting, just FI light flashing. Zero Clue what to do.

You probably will need to find someway to get the bike home or to a shop, as FI errors can be a multitude of issues,
Maybe someone will hope on and with a single thought fix your baby from his/her laptop.

What can shut off starter circut, Did you accidently hit the kill switch maybe, is the bike in gear when you are trying to start it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Thank you. I did get it from a dealer trouble is they are closed on Monday so now stuck at work with non starting bike. I was hoping for a quick fix like maybe it was running hot and shut down or something and it doesnt have any oil leaks so a bit confused. Again thank you for the manual and I will do more research in the forum
 

·
Registered
Joined
·
71 Posts
My bike (2011 Voyager)gave me the same code and light two consecutive rides. In my case it always happened right after starting the bike. I asked dealer about it and he said that sometimes if the voltage drops too low, these bikes throw codes. Not saying that is the situation in your case but I replaced my battery and have not had it happen since. The code I was getting was this.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
71 Posts
In my case was same flashing red light with FI symbol and Error 18 on screen


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
105 Posts
A low or diminished battery will also cause the ABS to not initialize due to the high current draw. Those battery tenders are worth having.
 
1 - 9 of 9 Posts
Top