Kawasaki Vulcan Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter #1
I'm not even sure if it has one, but lately my 900 Custom has randomly been sticking at a higher idle than normal and eventually will drop back down, it also occasionally when you crank back the throttle, the engine does not react immediately and when it does it hardly pulls then seems to suddenly react. It doesn't do this every time, but has a couple times here lately... Any ideas? Thanks, -Kyle
 

·
Registered
Joined
·
424 Posts
I'm not even sure if it has one, but lately my 900 Custom has randomly been sticking at a higher idle than normal and eventually will drop back down, it also occasionally when you crank back the throttle, the engine does not react immediately and when it does it hardly pulls then seems to suddenly react. It doesn't do this every time, but has a couple times here lately... Any ideas? Thanks, -Kyle
Yes the VN900 has a TPS SENSOR.

At what point does this happen, shortly after start or later during the ride.

If this happens within two minutes after the start, you might check the voltage on your battery.

If this is during a ride give the throttle cables a shot of oil, maybe sticking.
 

·
Registered
Joined
·
307 Posts

·
Registered
Joined
·
450 Posts
Remember to put the cover sheet on the TPS report :p
 

·
Registered
Joined
·
123 Posts
Discussion Starter #8
LOL and yes it seems to do it within the first few minutes of riding.
 

·
Registered
Joined
·
11,756 Posts
I'm not even sure if it has one, but lately my 900 Custom has randomly been sticking at a higher idle than normal and eventually will drop back down, it also occasionally when you crank back the throttle, the engine does not react immediately and when it does it hardly pulls then seems to suddenly react. It doesn't do this every time, but has a couple times here lately... Any ideas? Thanks, -Kyle
Possible sub-throttle problem.
 

·
Registered
Joined
·
424 Posts
LOL and yes it seems to do it within the first few minutes of riding.
Happens to lots of us. Called Run away high idle. Check your voltage on the battery. There is a low voltage check, after the start, that increases the rpm when low voltage is indicated. Rpm can go up as high as 2500 rpms. Really embarassing when it happens at a gas station. RMP will drop when voltage is improved or 2 minutes passes.
Started on mine in Feb, Checked my battery and it has been replaced. Issue solved.
 

·
BOTM Winner, December 2013
Joined
·
1,172 Posts
sounds similar to the problem my 900 had...about 5 times a year begining the second year it would stumble like that when id give it throttle...hooked it up to the computer at the dealer ... it had the code in the ecu 17 times for sub throttle actuator non responsive.....and did not put the fi light on even once....here is the kicker.. IF that is your problem then the actuator needs to be replaced it can not be purchased seperately (well here in canada anyways) so you have to buy the whole throttle body ....around $500-$700 i think .......i was thankfull for the extended warranty that day !!!!!

btw funny thing is my dealer has sold around 150or so 900s never replaced or diagnosed or sold a stator for a 900 BUT has replaced 4 throttle bodies and on one bike the harness for this issue....and this is the first time i hear of even a possibility of this problem on a forum......
 

·
Registered
Joined
·
424 Posts
The dealer that replaced my stator still claims he has never replaced one. Official line from Kawasaki is there is no problem with the stator, correct to a point, the problem is the plug into the regulator, leaks water, not sealed. Water gets in and shorts out the stator. Seal it up.
 

·
Registered
Joined
·
1,299 Posts
Bytehead, As far as I know my dealer still hasn't replaced one either. He wanted a grand to replace it; I spent about $250. He may never have to replace one.

I gotta wonder how many people get quoted $1000 and just put a new battery in and sell it.
 

·
Registered
Joined
·
424 Posts
Bytehead, As far as I know my dealer still hasn't replaced one either. He wanted a grand to replace it; I spent about $250. He may never have to replace one.

I gotta wonder how many people get quoted $1000 and just put a new battery in and sell it.
I saw the bill on mine 875 comes to mind. I walked away holding my EWARRENTY. But he will still deny he changed it. Think you may be right about slap a battery on and sell it.
 

·
Registered
Joined
·
498 Posts
Bytehead,

Is there a how to or where to seal it up? I ride my bikes pretty much rain or shine unless it's a downpour so I def. Don't want water getting where it shouldn't.
 

·
BOTM Winner, December 2013
Joined
·
1,172 Posts
The dealer that replaced my stator still claims he has never replaced one. Official line from Kawasaki is there is no problem with the stator, correct to a point, the problem is the plug into the regulator, leaks water, not sealed. Water gets in and shorts out the stator. Seal it up.
well if you are implying that the service manager is lying to me you have never been so wrong ....
 

·
Registered
Joined
·
424 Posts
Bytehead,

Is there a how to or where to seal it up? I ride my bikes pretty much rain or shine unless it's a downpour so I def. Don't want water getting where it shouldn't.
I really think my problem was washing the thing to much, water pressure. Because I was done riding in bad weather a long time ago. But I live in Texas so that is not much of a problem.

Take a look at the plug going in to the regulator not sealed at all around the wires. The plug itself is water tight but the wires are not sealed in the plug. Wrap with electrical tape if nothing else.

The majority of bike's that burn stators have reported finding water inside the plug when they opened it to do the test. Found it full on mine. So little wonder they burn up. Just a precaution if nothing else. Be sure the unplug the plug and check if there is any water inside. A lot of people use dielectric grease on the plug which will prevent the prongs from corroding.

Just a one time thing for some peace of mind.
 
1 - 17 of 17 Posts
Top