Kawasaki Vulcan Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
Hi all just installed sw front pulley,went arond the block and sounds terrible like a school bus, sounds like the belt is rubbing i did remove the part on the inside pulley cover as stated in the instructions. i did place the sw pulley with the lip facing the out side I hope this right the instructios did not specify. i did torque every thing down properly.can anyone tell me what i failed to do os missed ?:(
 

·
Premium Member
Joined
·
1,335 Posts
Hi all just installed sw front pulley,went arond the block and sounds terrible like a school bus, sounds like the belt is rubbing i did remove the part on the inside pulley cover as stated in the instructions. i did place the sw pulley with the lip facing the out side I hope this right the instructios did not specify. i did torque every thing down properly.can anyone tell me what i failed to do os missed ?:(
I am hoping to do the same installation next weekend. With the bike up on the jack and in neutral. Do you hear it rubbing when you spin the back wheel by hand? Maybe that lip goes to the inside? Hopefully, one of the folks that have installed this SW front pulley will enlight us?
 

·
Registered
Joined
·
851 Posts
Hi all just installed sw front pulley,went arond the block and sounds terrible like a school bus, sounds like the belt is rubbing i did remove the part on the inside pulley cover as stated in the instructions. i did place the sw pulley with the lip facing the out side I hope this right the instructios did not specify. i did torque every thing down properly.can anyone tell me what i failed to do os missed ?:(
I some what had the same problem, sound like the belt was rubbing or like a gear was grinding by the front pulley. What I did was realigned my tire and belt because it was off by 1/8" and I took off some tension on the belt. I still have the stock pulley but it did solve my problem.
 

·
Registered
Joined
·
696 Posts
I can't address your specific questions as to installation, as I've not installed one.

Is your SW pulley a new one? IIRC, some of the older front pulleys had issues that were finally addressed with a new design, last year maybe.

I did have a ton of problems with belt squeal when I first took possession of my 900, new from the dealer with stock pulleys. So, the fact that you're now running an SW pulley may not be the issue. The dealer goofed around with me/it for a month or so, until the left side of the belt had been chewed up so badly that the belt had to be replaced. That happened within a few hundred miles, so you want to make sure that you're not doing the same thing. Drive belts are rather expensive to replace.

My assumption would be that the belt is probably too tight and/or the pulleys are not properly aligned. I assume that you don't have a belt tension tool, so if you want to adjust it yourself, you'll have to do the hit or miss method, not loosening the belt too much at any given time.

hope that helps

Kerry
 

·
Registered
Joined
·
70 Posts
Discussion Starter #5
Wow you guys came to the rescue fast, i did just that I loosened the belt that made a difference I may take the bike to the bike shop just to check my allighnmnt nd belt tension before I go on a long ride thanks rob
 

·
Registered
Joined
·
70 Posts
Discussion Starter #6
OH YES IT IS IN DEED THE NEW GENERATION PULLEY i MADE SURE OF THAT BEFORE i ORDERED IT FROM MEANCYCLES.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #8
Yes bosco it was a good decision to order from meancycles.I still wish to know if the flange should be on the outside or towards the engine.FYI I recomend a impact gun there was no way that 27mm nut was coming offeven with a 3 ft powerbar! so I went out and bought one(electric 1/2 inch) worked wonders.
 

·
Premium Member
Joined
·
1,335 Posts
Yes bosco it was a good decision to order from meancycles.I still wish to know if the flange should be on the outside or towards the engine.FYI I recomend a impact gun there was no way that 27mm nut was coming offeven with a 3 ft powerbar! so I went out and bought one(electric 1/2 inch) worked wonders.
Found these photos on the SW front pulley installation. Flange goes to the outside, you did it right!!

http://s154.photobucket.com/albums/s257/jdpenn/Scootworks Front Pulley Install for Vulcan 900/?albumview=slideshow

Yeah, I do have an impact wrench, just need to get a 27mm socket. Did you use a torque wrench, or adjust the impact wrench to 90ftlbs?
 

·
Registered
Joined
·
84 Posts
The problem that I ran into was the pulley was rubbing on the pulley cover. I had to grind down some spots on the cover and the noise went away. All I am hearing now is a loud ticking noise when i am at idle, but that has nothing to do with the pulley.
 

·
Registered
Joined
·
210 Posts
When I replace the pulleys with the SW pulleys, I had to place a washer behind the plastic chrome coolant reservoir cover. It would rub every once in a while. There is only one bolt that holds it on and one washer did the trick.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #12
Thamks for research and the slide show,glad to know i got the pulley on the right way!I bought an electric impact gun it has 240ftlbs of torque so to tighten the sw pulley I used a torque wrench.
 
1 - 12 of 12 Posts
Top