Kawasaki Vulcan Forum banner

1 - 20 of 41 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1 (Edited)
So stator bit the dust a few months ago at 30,000 miles replaced it and rectifier. 3,000 miles later dead battery. Check output on stator got 23V at idle and 44 at 3,000 rpm. So replaced both again and dead again after a couple weeks. Thoughts? Rotor/magnet? Any way to test rotor?
 

·
Registered
Joined
·
11,756 Posts
Could you do this:

1. Take voltage reading across battery.
2. Turn on key and take another reading.
3. Leave key on for 5 minutes and then take another reading.
4. Turn key off for 5 minutes and then take another reading.

Post back with 4 readings.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3 (Edited)
1. 13.12
2. 12.8
3. 12.6
4. 12.91

Replaced battery again after last reinstall. Just fyi, after the last install, was on an hour ride and it seemed as though I would loose charge ability @ 80mph...ie. speedo would die(which I've learned evidences imminent failure of battery) I dropped speed to 60 and system resumed. I was able to make it back home (hour back) at 65mph. That didn't last long.

Just to clarify, did not start bike, just turned key on.
 

·
Registered
Joined
·
95 Posts
monitoring this thread. Good luck.
 

·
Registered
Joined
·
11,756 Posts
Could you do this:

1. Take battery reading.
2. Start engine and at normal idle, take another reading.
3. At about rpm that engine turns at 30mph, take another reading.

Post back with three readings.
 

·
Registered
Joined
·
11,756 Posts
Looks like you have a charging system issue.

Go through the tests in the sticky and post back with results/questions.

Rotor failures are practically never heard of.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #9
So, this is my question. Do I just put a third Rick's stator and regulator in there(which I have on hand)? I ordered a used magnet off fleabay. I am just at wits end with this issue.
 

·
Registered
Joined
·
11,756 Posts
Leave the reg/rect plugged in and repeat stator output voltage tests.
Push meter probe beside wires to touch contact in connector.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #16
Yeah, real hot. Plugged in to take for a ride to test. Went in for 2 min to grab gear, came out touched it and burned myself.
 
1 - 20 of 41 Posts
Top