Kawasaki Vulcan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I am in need of one of these right now and can't find one anywhere. Any help anyone could give me would be great.
 

·
Registered
Joined
·
39 Posts
I suspect that this will have to come from a dealer. They may not have one on a shelf but they can certainly order you one ...
 

·
Registered
Joined
·
536 Posts
I replaced mine when I did my stator to avoid problems but I almost thought it could have ben re-used. If yours came off in decent shape you may try coating it with silicone spray and squeegeeing (not sure if that's a word) it with your fingers to clean it up some. I would have bet mine would have been ok but I already had a new one. If you try this just be sure both surfaces are cleaned up real good and the gasket is as straight as possible since it can get a bend in it and be creased a little. If you didn't tear it on removal it should be able to be saved. Here's hoping.
 

·
Registered
Joined
·
698 Posts
I replaced mine when I did my stator to avoid problems but I almost thought it could have ben re-used. If yours came off in decent shape you may try coating it with silicone spray and squeegeeing (not sure if that's a word) it with your fingers to clean it up some.
If you're going to all that effort then why risk an old gasket? You'd spew if it leaked after putting it all back together again.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Ok this sucks.. changed out both the regulator and the stator.... battery continues to lose voltage while running. Could this just be the battery?
 

·
Registered
Joined
·
536 Posts
Did you do all the tests with the multi-meter that are suggested before and after the stator and regulator were replaced?
If not you should probably read the info in this stator information link and test everything to be sure your charging system is right. If you didn't you are just guessing. http://www.vulcanforums.com/forums/showthread.php?t=24679
 
1 - 8 of 8 Posts
Top