Kawasaki Vulcan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Ok when i turn ignition on I get the normal F1 light come on and buzz then goes off as it should do,then light goes out.Start bike up but I get the same buzzing noise as if the F1 is doing ignition check again without the F1light on but buzzing never stops.Hope that makes sense.Can anyone put my mind at ease as to where and what to look for.Oh it's a Vn900 Custom se.
 

·
BOTM Winner, December 2013
Joined
·
1,172 Posts
probably just the fuel pump ..
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Guess its nothing to worry about but I do get a strong smell of petrol after start up but there is definitely no fuel leaks anywhere.If its just a noisy pump I will settle for that.Thanks Big Worm.
 

·
Registered
Joined
·
7,620 Posts
Guess its nothing to worry about but I do get a strong smell of petrol after start up but there is definitely no fuel leaks anywhere.If its just a noisy pump I will settle for that.Thanks Big Worm.
The FI system is kind of noisy. Ticking fuel injectors, buzzing fuel pumps, etc., wouldn't worry too much.

The fuel smell is probably just from being a smidge rich right at startup. It's a throttle body injection system, meaning the injectors are in the throttle body not in the cylinder heads or otherwise. So it's likely to be a little 'sloppy' at startup as there is some distance between the engine and the injectors and I imagine it doesn't atomize as well when there isn't much airflow (like when the engine is up to idle speed or better)!

Edit: Nevermind, sfair says you should get that checked out, so, you probably should!!
 

·
Registered
Joined
·
11,748 Posts
Some Kawasaki 900's had a recall for a fuel hose connector issue.
There should never be a smell of raw gasoline at any time, so you had better check that out.
 
1 - 6 of 6 Posts
Top