Kawasaki Vulcan Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hi
I just took the Vulcan home Thursday 100 km trip . Wow what a ride 70 to 80 km side winds. Bike was pretty good in the wind though:p

I just had one thing that I noticed the Signal lights thumb button sticks some times. Anyone having the same trouble?:confused:

I will be taking it to dealer for a baseline check and get a good starting point then I will be able to start doing my own maintenance.
 

·
Registered
Joined
·
424 Posts
Hi
I just took the Vulcan home Thursday 100 km trip . Wow what a ride 70 to 80 km side winds. Bike was pretty good in the wind though:p

I just had one thing that I noticed the Signal lights thumb button sticks some times. Anyone having the same trouble?:confused:

I will be taking it to dealer for a baseline check and get a good starting point then I will be able to start doing my own maintenance.
Welcome glad to have you here. You just took the first step on a long and plesant journey.

That thumb button will stick at time, dirt and particals get inbetween the slide, it normaly works it self free. not anything to worry about.

Oh and by the way 'NO PICS YOU DON'T EXIST' we like to see the pretty pics. :)
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Yeah kind of thought there was something guke wise stuck in there,
Hopefully doesn't happen when I take my D exam
 

·
Registered
Joined
·
711 Posts
I never had any issues but I'm sure there's nothing to worry about. Give it time to fully break in and I'm sure I'll fix by itself.
 

·
Registered
Joined
·
976 Posts
I had the thing apart the other day. Just a spring and a couple switches in there an I can't remember. I cleaned it up with alcohol and sprayed it with tripple lube. Hasn't stuck since.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
I had the thing apart the other day. Just a spring and a couple switches in there an I can't remember. I cleaned it up with alcohol and sprayed it with tripple lube. Hasn't stuck since.
Thanks I will try this if it continues:)
 

·
Registered
Joined
·
3 Posts
I just encountered this today and its isolated to the right. I was wondering if lubing with wd40 would be ok (with the switches and springs inside). Thanks!
 

·
Registered
Joined
·
19 Posts
Discussion Starter #9
I found that i was kind of pulling up on the switch cause I have short thumbs
It worked correctly when I pulled straight across the switch plane and I don't have a problem with it sticking at all.

Hope this helps
 

·
Registered
Joined
·
3 Posts
Smidbike - That may be the case! I also have short thumbs. When pushing (right turn), it tends to stick at times.

The only thing I can think of, is that this occurred after washing the bike (sat in the garage for 3 days). Perhaps water/dirt got in? I'm tempted to blast some WD40 in for good measure but unsure if this will harm whatever is inside there.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #11
I don't think wd40 will hurt could help clean all the crap out of there., I tried using wd40 didn't help my situation but didn't change how switch operated either,still had same result then I realized how I was trying to engage the turn signal switch,
 
1 - 14 of 14 Posts
Top