Kawasaki Vulcan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Finally!
I was able to successfully install my recently purchased motorcycle stereo. I opted for the 100w version incase I ruined anything. But alas! Success!


Ride safe!
 

·
Registered
Joined
·
658 Posts
Nice job. How does it sound at speed?
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Great question truckie, unfortunately it's raining and in the 30's here! I might sneak a ride in and let you know tomorrow. Bought it on Amazon for $51 and mounted it with the mirror thread.
 

·
Registered
Joined
·
182 Posts
Shark audio

Those aren't the amped speakers are they? If not, can you show us where the amp is mounted? thanks
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
I'll post a picture of where I mounted it in the morning, I'm proud of my installation job with no instructions! :)
 

·
Registered
Joined
·
7,620 Posts
And these are waterproof? Man that's a nice setup for $51 Is the amp waterproof?
 

·
Registered
Joined
·
1,159 Posts
Thanks for the video. I have a 100W system (2050A if I remember right) in my stack of stuff to be installed soon. I went with the black instead of chrome and am hoping to be able to hide everything inside the fairing. We'll see how that works out and I'm interested to hear what you think of it at cruising speed.
 

·
Registered
Joined
·
76 Posts
i have that same exact radio and have no problems really hearing it at speed. You have to make sure you dont put the treble too high, if you do at high speeds you will lose some of the clarity but it is a relatively easy install and a hell of a deal at $51. I paid $109 for it a couple of years back. i have my head unit in a front fork bag.
 
1 - 10 of 10 Posts
Top