Kawasaki Vulcan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
223 Posts
Discussion Starter #1
I would like to ask if this has happened to anyone before. While pushing my 1700 Nomad around my garage today, suddenly the throttle grip came loose and slid out near the end of the handlebar. I don't mean just the grip. I mean the entire sleeve moves out as far as the cables will allow. I nearly dropped the bike when this happened. When I slide it out of the housing, I can see the end of the sleeve has a notched black ring around the circumference. I can slide the sleeve back in and it kind of seats back in ,but it will slide right back out very easily. It's like something completely separated. I am glad this didn't happen on the road, and the bike is definitely not rideable. Can anyone suggest what this is all about? Did I break it when I was pushing the bike around?
Thanks in advance for any help, Eric
 

·
Registered
Joined
·
226 Posts
I have a complete throttle grip in front of me (spare), it is a white plastic sleeve, inner chrome ring, black rubber grip, and chrome end cap. There is no notched black ring. Is yours a stock grip or aftermarket?
 

·
Registered
Joined
·
676 Posts
It's hard to picture what you mean. Is the entire switchblock loose, so the whole throttle side assembly moves? There's a screw in the inner front, and a chrome cap on top, to keep that in place. It may just require tightening up.
 

·
Registered
Joined
·
223 Posts
Discussion Starter #4
I have show chrome comfort heated grips. It must be the show chrome sleeve that is different from stock. Sorry about not specifying that. The whole sleeve assembly comes out of the housing. When I slide it outwards, I can see the notched end of the sleeve. It will slide back into the housing and lock in the notches so I can rotate the throttle. But it won't stay in. It will come right out and slide ont the handlebar a couple inches before the cables run out of slack.
If this happened out on the road, I probably would have crashed.
 

·
Premium Member
Joined
·
1,707 Posts
Sounds like something let loose for sure. Normally the glue job will come loose from the heat. I wouldn't trust it without taking it apart and having a good look. But almost any throttle sleeve will work on these. Kawasaki, Yamaha. Honda, Harley....

We had heated grips on our patrol scoots and the grips would always separate from the sleeve, but not the sleeve come out of the housing. I would even say that the show chrome sleeves are defective. Compare the show chrome cable stays with the stock grip.

A pic would help....
 

·
Registered
Joined
·
226 Posts
From your description it sounds like the switch housing has broke, allowing the sleeve to come loose. If the sleeve had broke the cables would not be coming out. As mentioned, a photo or 2 would really help........
 

·
Registered
Joined
·
223 Posts
Discussion Starter #7
Thanks for the responses guys. It's hard to describe what happened. The whole grip sleeve is broken free from the housing.
Lucky for me, I saved my original throttle sleeve, so I am going to put it back on today.
The Showchrome grip is obviously defective
 
1 - 7 of 7 Posts
Top