Kawasaki Vulcan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Changed oil and filter last night-put in recommended 3.1 L oil- oil did however seem to be a bit high in the sight glass.Was some slight smoking on pipes ( close to crankcase) when went for a ride after ( not blowing white smoke or anything )
Two hours after the ride the crankcase was still very hot to the touch-never noticed that before-dont think thats normal after such a long period has elapsed. Could it be from having slightly overfilled the crankcase ?
cheers
 

·
Registered
Joined
·
152 Posts
A rough idle is the first thing you would notice with an extremely over filled crank case. I haven't seen over filled oil do that
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
I drained a bit of oil from the crankcase and went for a ride-still running very hot-thought I would check the coolant-took off the right side cover and think I found the culprit.The coolant level was good-but a hose running from the top of the coolant reservoir looked loose-I tugged a bit and it came loose from somewhere-nice !! not sure if my slight tug did the damage ( don't think so) or it has been detached for a while-can you geniuses tell me where the top hose connects to ? the longer bottom one goes to the radiator cap under the tank I presume-took some pics-will try and post.
 

Attachments

·
Registered
Joined
·
11,756 Posts
The hose you tugged on should dangle out the bottom of the bike. Not the problem.

Is the fan running more?
Is the overtemp light coming on?
Are you checking the oil level with the bike perfectly vertical? It does not take much of a lean to change the sight glass level.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
sfair
many thanks reply-really !! wow- thought it definitely connected somewhere-so its just one of the about 3 hoses that are tied together around the oil drain plug area ? guess I'll have to just put it back- the fan seems to be working as usual and the over heating gauge has not come on- everything seems hot to the touch though-even the gauge cluster housing was hot after my ride .as was the round air filter looking goodie on the right side of the bike-is that normal ?
cheers
 
1 - 7 of 7 Posts
Top