Kawasaki Vulcan Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
658 Posts
Discussion Starter #1
Hey guys,

this may be a dumb question, but, how do I remove my rear turn signal stems from my 900 custom? Do I need to remove my rear wheel to get under there?

thanks.
 

·
Registered
Joined
·
100 Posts
I will be doing this this weekend I have I light strip brake and turn coming from radiantz it should be here Thursday. So if no one has answered by then I should be able to help.
 

·
Registered
Joined
·
658 Posts
Discussion Starter #3
Thanks I appreciate it, actually, your post about license plate relocation is what got me thinking about this. Nothing as radical as you, just a little clean up on the OEM bracket.

I will be doing this this weekend I have I light strip brake and turn coming from radiantz it should be here Thursday. So if no one has answered by then I should be able to help.
 

·
Registered
Joined
·
498 Posts
I don't have a custom but on the classic you remove the chrome cover, unplug the light then there is a 15mm I think nut that you loosen and remove the light.
 

·
Registered
Joined
·
658 Posts
Discussion Starter #5
How did your install go? Any pics of the new mount and light?

I will be doing this this weekend I have I light strip brake and turn coming from radiantz it should be here Thursday. So if no one has answered by then I should be able to help.
 

·
Registered
Joined
·
100 Posts
Sorry guys haven't had time to install anything yet have a four month old and now my mother is in the hospital so it may be a little while before I have it installed will post pics once I get everything taken care
 

·
Registered
Joined
·
658 Posts
Discussion Starter #7
I have an 18 month old at home myself. So I can totally understand. Congrats. Sorry to hear about you mom, hope she gets better.

Sorry guys haven't had time to install anything yet have a four month old and now my mother is in the hospital so it may be a little while before I have it installed will post pics once I get everything taken care
 

·
Registered
Joined
·
100 Posts
Thanks man
 

·
Registered
Joined
·
100 Posts
Here is a couple pics I have my radiantz led lights on now. Next I will mount up my side plate bracket and wire up my plate bolt lights and take off my turn signals I hopefully will get this done Saturday morning. I figured out I can get things done if I do them early in the morning before the wife and baby wakes up lol. I'll also post pictures of my mock up plate. I still need to get spacers and longer bolts. By the Time i get to run to the store all or the parts and hardware ones are closed.
[/IMG][/IMG][/IMG]
 

·
Registered
Joined
·
658 Posts
Discussion Starter #12
Thanks for the pics. looking forward to the rest of the install.

How is your mom doing? and the little one?
 

·
Registered
Joined
·
100 Posts
She's doing ok she's has two aneurysms and needs surgery but I think the dr. Found them early that it will all be fixed next week with no complications thanks for asking. And as for my baby's she's good just keeps you busy and tired lol sleep is in short supply around my house but I wouldn't trade it for the world she just turned four months on the 5th
 

·
Registered
Joined
·
183 Posts

·
Registered
Joined
·
100 Posts
[/IMG]Here it is with the running lights on tomorrow is the day I remove my turn signals and install my side plate will post pics when done
 

·
Registered
Joined
·
100 Posts
Got the plate on finally lol here's a pic taking turns of now they'll just gave to blink fast until I hook up my load equalizer maybe if I can get it on now if I hurry.
[/IMG]
[/IMG]
[/IMG]
 

·
Registered
Joined
·
658 Posts
Discussion Starter #17
Looking good.
 

·
Registered
Joined
·
100 Posts
Here's a pic with the tail lights gone I got my equalizer on
[/IMG]
[/IMG]
[/IMG] I was dark I can take better pics tomorrow.
 

·
Registered
Joined
·
100 Posts
[/IMG] I love a nice clean rear end nothing is better lol
 

·
Registered
Joined
·
658 Posts
Discussion Starter #20
[/IMG] I love a nice clean rear end nothing is better lol
Nice, looks awesome. did you just cut the wires for the OEM signals or were you able to access the connecting plugs?
 
1 - 20 of 24 Posts
Top