Kawasaki Vulcan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
Hi Everyone! I have a 2009 Vulcan Classic LT 1700 with about 35,000 miles. I bought it used from a dealer about nine months ago. I ride it everyday and put on about 90 miles each day. I was driving up a slight grade at about 75 MPH when I heard a "POP" and immediately following was the sound of something spinning hitting a fixed object. Another way to say it would be like the sound of a card rapidly slapping bicycle spokes. I did not see any liquid or smoke nor did the bike lose power. At first I thought I hit something and it stuck to my front wheel causing the rubbing sound. The sound stayed with me until I stopped the bike at work a few miles down the road. The bike was parked all day and when I got on it to go home the rubbing sound was gone, but I now have a rattle coming from the lower front area. It sounds similar to the pinging noise the engine makes when accelerating after using bad gas except I hear it all the time now, even when idling. It's not very loud, but I notice it. Any ideas?
 

·
Registered
Joined
·
2,656 Posts
Pull the oil screens to check for metal in them. I had the KACR fly off and the pieces got caught in the oil screen.
 

·
Registered
Joined
·
364 Posts
I'd check for simple things first...

It's been a while since I sold my Classic LT, but I would think it possible that something could get caught in the fan shroud...or worst case, something caught and broke off one of the fan blades...check if something is rattling around in there.

...and keep us posted!
 
1 - 3 of 3 Posts
Top