Kawasaki Vulcan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
953 Posts
Discussion Starter #1 (Edited)
To the guys who know tuning,

I installed a Cobra HP2-1 exhaust last Friday, as well as a Dobeck performance Electronic Jet Kit. The bike didn't run very well so I lowered the EJK suggested settings down 2 notches in each zone. It was running great. :D:D

Today my Barrons BAK arrived. I installed it, tuned the EJK to suggested settings and took off. I cannot believe how much backfiring or "popping" I have.:mad: I cannot change gears without embarrassing myself from all the darn noise. :eek: Has anyone had this problem?:confused:

Is the excessive backfiring from running too rich or too lean? Anyone running a similar setup, please share your knowledge and experience.
 

·
Registered
Joined
·
50 Posts
I don't have the same fuel management system as you but I do have Cobra pipes and BAK, I didn't notice any difference in noise level on mine. I am running the Fi2000 and didn't have to change any settings after the BAK install... I had backfiring but that went away when I installed the quiet core baffles.
 

·
Premium Member
Joined
·
1,130 Posts
To the guys who know tuning,

I installed a Cobra HP2-1 exhaust last Friday, as well as a Dobeck performance Electronic Jet Kit. The bike didn't run very well so I lowered the EJK suggested settings down 2 notches in each zone. It was running great. :D:D

Today my Barrons BAK arrived. I installed it, tuned the EJK to suggested settings and took off. I cannot believe how much backfiring or "popping" I have.:mad: I cannot change gears without embarrassing myself from all the darn noise. :eek: Has anyone had this problem?:confused:

Is the excessive backfiring from running too rich or too lean? Anyone running a similar setup, please share your knowledge and experience.
Have you removed the PAIR (secondary air) system yet? Some simply put a marble, or a wirenut, in the hose coming from the air cleaner to the solenoid valve. I would start there. There's another thread that covers the marble technique. Other than that, I would look for a hose or a cap that's come dislodged accidently while you were removing the OEM air cleaner and installing the Barons. Sorry I'm not familiar with the Dobek product you've installed. I do have the BAK and Cobra Speedsters as well as the PCV & Auto Tune. My PAIR was removed the day after I brought the bike home and I've removed the secondary throttle plates too. You know better what you touched when you installed the BAK so go back over your work and see if anything's a miss. Good luck
 

·
Registered
Joined
·
991 Posts
900 with Big Air

I put the Big Air kit on both of my bikes, a V2K and my 900C. I tried a fuel controller on the V2K and removed it shortly afterward. The V2K runs rich enough to handle the Big Air kit on its own. On my 900, I was going to try a controller but figured that if one bike ran ok, why not try the other. I run Cobra HP 2into1 and the Big Air without the controller and it runs fine, no backfire, no pop etc.:cool:
 

·
Registered
Joined
·
953 Posts
Discussion Starter #5
Thanks to you guys that gave me some ideas as to what my problem may be. I went and looked the bike over again in the sunshine and found a vacuum line disconnected. I appreciate your help. Keep the shiny side up!::D
 
1 - 5 of 5 Posts
Top