Kawasaki Vulcan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter #1 (Edited)
It would be great if we could keep this thread focused on the PowerPro black (Continuously Variable Tuning - CVT) so it can be a resource for people that buy the Cobra unit. I know there are several options but good information on tuning is hard to find. I used the search function here and the thread normally turn into a debate which makes it harder to distill the information you are looking for to tune this fuel management system

So I did the big three and did some riding last night and had some lag between 1st and 2nd gear when I jumped on the throttle. The only good information I found was users on the HD sites and there wasn't much to take away. This was the best I've found so far:

Acceleration feature

Just a little more feedback on my powrpro black so far. Logged I about 100 miles so far. Lots of testing. From cobra the cruise is 5ms whatever that means. From cobra the acceleration is 1.3ms.

Remove all the fuel added on the acceleration feature and it will knock out the hesitation I get sometimes when I crack the throttle wide open. Cutting the fuel up a few ticks to 1.7 made it a lot worse, 1.4 was really bad. I guess overfuel. It actually bucked like it was drowning in the upper revs. Least that’s my take. Dialed down to .8 ms on the acceleration setting it seems to have the most power.

It threw me back in my seat and startled me honestly but it could have been my attention span to holding on. Further on down I dialed it to .2 ms and I did not detect any hesitation at all when I cracked the throttle wide open.

Gonna ride it here for a few days and check the plugs. If they are white like they were without the cobra unit back to .8 ms it goes. So on and so forth. It is a super easy device to tune and if it wasn’t for my ocd I wouldn’t be fiddling with the settings but I don’t want any hesitation or pauses when I go wide open. The warrior is a wonderful machine to rip the throttle. Anyways that’s what I’ve learned so far. And my feedback is so far positive
So for the people using the PowerPro Black can you post if you had an issue once you installed the unit and the resolution. Obviously I am looking for how you resolved the lag but posting all the issues and the resolutions would build a great library for people that either have or will buy one of these units.
 

·
Registered
Joined
·
218 Posts
I have the PowerPro Black, but am running stock pipes. I am running the Cobra intake though. For me, I've been fortunate, no need to change anything on mine, runs like a champ. Sorry I can't be more helpful. But I hope this thread is grown by the time I get the funds for pipes in case I have issues at that time.
 

·
Registered
Joined
·
93 Posts
Discussion Starter #5
D0ncH, I would agree and have been logging some miles the last couple days. Not sure if it's a good thing but my drive to work is about an hour so it's going to be easy.

My factory settings were 4 at cruise and 1.2 acceleration. About half way to work I backed the acceleration down to .8 and any hesitation disappeared and the throttle response really improved. We'll see how she does on the ride home but this morning after the slight adjust she ran pretty damn nice.
 

·
Registered
Joined
·
93 Posts
Discussion Starter #6 (Edited)
So it's been almost a month and I figured I would post to let the folks here know where i settled on the fuel management system.

I have cruise set at 5 and left the accelerate at .8. With the acceleration at the factory setting of 1.2 there was a fairly consistent hesitation if I jumped on it between 1st and 2nd gear, every other shift there was no hesitation. The adjustment down cleaned it up so the only thing I can think of it was just pushing to much fuel and was bogging down.

After talking Rick, the gentlemen that essentially programmed the FMS he suggested that I up the cruise to 5 reduce the decel pop. It did work pretty well, I still have some mild popping but it's the nature of the beast with the Cobra swept over factory exhaust.

He did tell me something pretty interesting, that the module is really for the pipes and have very little to do with the Cobra intake. If your looking for real help with this unit the tech's a Cobra, specifically Andre offer nothing but arguments. All this gentlemen did was repeatedly tell me to read their article on decel pop after I told him on five different occasions I read it. Blamed the bike, the dealer installation and offered very little assistance. He was a fairly arrogant and unhelpful SOB.

Anyway the system is working well, bike runs pretty damn clean and I get 41 to 47 MPG depending on where and how I ride.
 
1 - 6 of 6 Posts
Top