Kawasaki Vulcan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi Guys..I`ve purchased a power commander V for my 2009 VV..The instructions show 2 wires that are connected to the stock ECU.I don`t seem to have these 2 wires coming out of the power commander V.I only have the wired harness to the Injector bodies & one wire which connects to the throttle sensor. Could anyone out there give me any info on this please..cheers guys..ride safe...
 

·
Registered
Joined
·
574 Posts
I'm guessing you got the 17-006 model without the ignition advance. Is that the case?

The one with the ignition advance ((17-003 )should also have wires going to both coils. The two wires from the ECU are the Crank position sensor wires, so the PCV can phase the compression stroke.

I went to Dynojet's site and looked at the install PDF for the 17-006 non ignition model, and it does show the ECU wire hookup.
You should call them and ask what the deal is.
 

·
Premium Member
Joined
·
2,115 Posts
The very first model that came out for the Voyager was the 17 – 005, I think it was.
I bought it when it first came out back in 09. Anyway it did not have the wires going to the ECU. I sold it a long time ago and got the 17 – 033(with ignition).
Can you tell us the model you got?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4 (Edited)
...Hi..I`ve got the 2009 model..Had it from new...got 12k on clock now.Fitted D&D exhaust along with the K&N air filter.I`m hoping the Powecommander will give it a little more umph...It appears I have the earlier Powercommander model..got it on american ebay at half the cost of new in UK...
 

·
Premium Member
Joined
·
2,115 Posts
...Hi..I`ve got the 2009 model..Had it from new...got 12k on clock now.Fitted D&D exhaust along with the K&N air filter.I`m hoping the Powecommander will give it a little more umph...It appears I have the earlier Powercommander model..got it on american ebay at half the cost of new in UK...
No I mean what model number (or part number) of the PCV you have.
Have you got it installed yet?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
...sorry.. thought you meant my voyager...The PCV is used..I got it off ebay..I hav`nt fitted it yet.There ar`nt any visible model description on thePCV..There is a bar code sticker on the rear but it has been partially covered by the velcro fastener..I`ve noticed that there are issues regarding the Ignition retard on the newer PCV owing to engine temp..will this also be an issue with this former version.I`m only looking for a small improvement..basically just to prevent my motor running to lean...thanks for your reply...
 
1 - 6 of 6 Posts
Top