Kawasaki Vulcan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter #1
Does anyone know if a Power Commander III USB will work on an 09 900. Some of the sites that sell them say 06 to current, some say 06 to 08 and the Dynojet site only lists the PC V for the 09. I would like to use the III for the option of the non computer adjustment as well as the PC.

TIA
Max
 

·
Registered
Joined
·
68 Posts
I have the Power Commander III on my 09. I've been experimenting with the maps from 08. The 09 maps with look to be the same variations (at least same names) as the 06-08 but the 09 specific only work with the PC-V.

I need a map for stock pipes debaffled but have been unable to locate any.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #4
I decided to just get the PC V. It was only $20.00 more than the III is smaller and has quite a few more features. It should be here to wards the end of the week. I can't wait to get it hooked up and take it for a ride!
 

·
Registered
Joined
·
117 Posts
Discussion Starter #5
The PC V made it on Friday. I had a bunch of things to do on Saturday, so I didn't get time to work on it until Sunday. There is an orange wire at the ECM near the speed sensor, but that wire isn't the correct one. So, I had to remove the tank to get to the water temp sender. I ran the bike and took some readings with a laser thermometer and meeter. I opened the temp application and entered the values. This is where I ran into a problem! The only reading I could get on the computer display, was the first value on the temp table. I started at 80 deg on the scale and no mater how hot the bike was, 80 was the only temp that it would read. So, I took the bike back apart and double checked all of the connections. I re ran the bike and double checked my readings. After changing a couple of values, I ran another test. Same results! At this point, I am thinking I have a bad unit and walked away. Then I had a thought and hooked the laptop back up and checked the firmware version. It wasn't the latest from Dynojet. I downloaded and updated the PC V and did another test...... It worked! Now if it would quit raining long enough to ride this thing......... I will report on how it runs when I get some decent weather.

Anyone that buys a PC V should check the firmware before you install, if you are going to use all of the features.
 
1 - 5 of 5 Posts
Top