Kawasaki Vulcan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi guy`s i have a power commender 5 on my kawa vulcan 1700 2009, i dowload the site for it to try find a map, but i can find any map for this bike,i have cobra mufflers and a air filter modify , am not sure what is the brand of the air filter but it as a sword on it. When i slow down it make big backfire ,but that only occurs a few time , if somone can give me ideas how to fix it that will be very nice.

Thank`s
 

·
Registered
Joined
·
281 Posts
Hi guy`s i have a power commender 5 on my kawa vulcan 1700 2009, i dowload the site for it to try find a map, but i can find any map for this bike,i have cobra mufflers and a air filter modify , am not sure what is the brand of the air filter but it as a sword on it. When i slow down it make big backfire ,but that only occurs a few time , if somone can give me ideas how to fix it that will be very nice.

Thank`s
Open the software on the computer. Connect the computer to the PCV. Hit get map. In the 0% throttle column add 5 to all the cells in the RPM range of the pops. Probably between 1700 RPM and 2200 rpm. This will add a little fuel at zero throttle and make the environment in the pipe non conducive for reignition in the hot exhaust. First and foremost you need to plug the Air injection valve hose at the 11 o'clock position in the right side dogbowl. This will cause most of the popping no matter how you map if you dont block the hose.

If you dont have a decent map, you either need to dyno tune or hit up David Sheek on this forum and he can send you a map. He will need your email.
 

·
Registered
Joined
·
644 Posts
Also make sure you calibrate the throttle position in the PCV.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Thank`s guy`s, i did calibrate the throttle and it work like new :)

Thank`s again for all the info.

jacob 51
 

·
Registered
Joined
·
580 Posts
How do you calibrate the throttle position to the pcv.
If you go into the power commander tool menu then click on calibrate. Mine was set properly at zero throttle from the factory.
 
1 - 7 of 7 Posts
Top