Kawasaki Vulcan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
Hi all,

I have been looking to replace my plug wires. Not sure they need to be but with 70K miles not sure it is a bad idea. They do not look dry rotted or anything. Anyway, in the OEM parts they only list the ends and not the wires themselves. I measured the wire diameter and it is 7mm. There are 7mm Excel universal kits but they do not have the same type of ends. Anyone have any thoughts on new wires or have changed them out on the 900? :confused:
Thanks and Drag-on!
 

·
Registered
Joined
·
11,756 Posts
My opinion only...if they look good and the bike runs like a champ, leave them alone.
If and when they start to fail, you will be given plenty of warning.
 

·
Registered
Joined
·
1,324 Posts
Talk to a dealer to find out the details, but the plug cap is removeable. In the parts list it's shown separately from the plug wire. In the past I've seen caps that screw onto the wire, but I'm not pulling mine apart to check.
 

Attachments

·
Registered
Joined
·
125 Posts
Discussion Starter #4
Thanks guys I appreciate the information. Interesting about them screwing on. I would not have thought about that. I always try to be proactive and was also wondering if I could get a better fire with new wires. They are stiff unlike wires I have seen on cars but not sure if that is a issue. Otherwise they look fine after 70K miles. I will talk to my dealer as suggested.
 
1 - 4 of 4 Posts
Top