Kawasaki Vulcan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter #1
Glad I ordered these through my local dealer. They don't line up at all. Must be wrong parts in the right box. They were new from cobra, factory wrapped and everything. Now I'm waiting for the dealer to square it away with Cobra. Everything else have from Cobra has been plug an play.
 

·
Registered
Joined
·
85 Posts
Hopefully Cobra just made a packaging error. My floorboards fit perfectly, just like an OEM part.
 

·
Registered
Joined
·
163 Posts
Discussion Starter #3
Hopefully Cobra just made a packaging error. My floorboards fit perfectly, just like an OEM part.
That's what I'm thinking. There is no way these brackets fit on a Vulcan 900. I'm pretty sure they will figure it all out. Wish I had the boards though! The wife's sneakers are getting melted... :)
 

·
Registered
Joined
·
8 Posts
Sorry to hear about your troubles! Has your dealer been in contact with us already? If not, make sure they give us a call at (714) 692-8180, and one of our customer service reps will get this taken care of.

Thanks for your patience and support!
 

·
Registered
Joined
·
163 Posts
Discussion Starter #5
Sorry to hear about your troubles! Has your dealer been in contact with us already? If not, make sure they give us a call at (714) 692-8180, and one of our customer service reps will get this taken care of.

Thanks for your patience and support!
After my dealer sent photos of the problem, you guys are taking care of it. Probably just wrong parts, right box. Everything else I have from Cobra is first class, and these boards were too, just not made for my bike. It happens. Thanks for taking care of it.
 
1 - 5 of 5 Posts
Top