Kawasaki Vulcan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I bought this bike several months ago with about 17000mi on it. I have never had any problems mechanically wrong with it. One issue i do have though is my ignition button has somehow dislodged itself from the from of the housing unit. I have to stick my pinky in with no glove on to hit it to start the bike. It makes getting going a little slower. How can i get it to come back out firmly?
 

·
Registered
Joined
·
311 Posts
You need to take the housing apart and see what the problem is, May be a broken spring. Should be easy to repair.

Welcome to the forum :)
 

·
Registered
Joined
·
104 Posts
I bought this bike several months ago with about 17000mi on it. I have never had any problems mechanically wrong with it. One issue i do have though is my ignition button has somehow dislodged itself from the from of the housing unit. I have to stick my pinky in with no glove on to hit it to start the bike. It makes getting going a little slower. How can i get it to come back out firmly?
it happend to my old 750, the plastic lugs that stop it from going all the way in had worn and the spring could not press it back,
what i did was drill a tiny hole in it and put a small self tapping screw in it so i could pull it back, soon it will start to stick on and burn out the starter ,

take it pices and have a look to see if you can fix it , finding a nother one maybe hard,
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks for the help. I'm gonna take it apart this weekend to see what the deal is. I'll post what the problem was. Thanks for the invite.
 
1 - 4 of 4 Posts
Top