Kawasaki Vulcan Forum banner

1 - 20 of 36 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
The Bike: '08 900 Custom
The Pipes: HK 2 into 1 Sideburner
The Intake: Baron's BAK
EFI Tuner: Cobra fi2000r

I have tried 2-1-1 and am currently set at 2-2-1. At the current setting the bike idles smooth, I get no excessive popping on decel but i think that at higher speeds (65-75mph ACTUAL) it doesn't run as smooth as it did with stock airbox and no fi2000. I think roll-on throttle should be a little stronger too. So I am thinking that the 2nd and 3rd pots need adjusted but the first pot should stay where i have it.

I have the tuning instructions but I haven't had the time to thoroughly go through them and fine tune the bike, I was wondering if anyone with a similar setup could share their pot settings for me to try.

Thanks
 

·
Registered
Joined
·
2 Posts
I know this is a little late but if you havnt figured it out yet throw the cobra suel controller in the trash, i did and picked up a power commander V, fixed all my lean/rich problems. FI2000s are junk.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #3
I know this is a little late but if you havnt figured it out yet throw the cobra suel controller in the trash, i did and picked up a power commander V, fixed all my lean/rich problems. FI2000s are junk.
No offense but I'm not asking for opinions on which tuner is better than the other, i'm asking for help with the one i already have.....
 

·
Registered
Joined
·
941 Posts
I think if you contacted cobra they might be able to help. I know I have the Fi2000 and Hard Krome pipes but no intake. And I turned mine all the way down to 0-0-0 which should be like if the computer wasn't there. But it seems to have made my mileage worse (Calculated over the last 1000 miles). So I plan to bump it back to the default setting.
 

·
Registered
Joined
·
719 Posts
I'm running 4-2-0. Tried a bunch of settings. 4-2-1 runs good but too much gas smell at idle. Check your spark plugs after making changes and riding a bit.
 

·
Registered
Joined
·
54 Posts
I am going thru the tuning phase as well.
My setup:
900 Custom
Cobra Dragster pipes
BAK
Fi2000

I started at the default 4-2-0 and tweak a little each time I ride. Right now I am at 2.5-2-1. I have decided to focus on getting the first (left) pot right and will then move on to the middle one.
I have been bringing the first pot down from 4 in 0.5 increments. Now at 2.5. It is running much better as I come down.

BTW, I tried a technique that was posted here: For the first (left) pot, run the bike at 2000 rpms and increase the first pot from 0 until rpms start to drop. Then back off a touch. When I did this, as I reached about 3.0 the rpms started to pick up. Didn't really work out well. I'm mostly using the admittedly subjective approach of riding and tweaking.
 

·
Registered
Joined
·
171 Posts
I have an air filter similar to the one that Baitis has (UNI foam) and Bub Jug Hugger pipes. I started experiencing some popping when decelerating and as suggested by Baitis changed my settings on my Cobra to 3-2-1. It seems to have taken care of most of the popping but I think the nature of the pipes causes some of this. Last mileage check just over 50 mpg, that's mostly highway riding.
 

·
Registered
Joined
·
533 Posts
Mine is at 2-2-1 (Cobra Longs, Ness intake), and it runs very nicely at all speeds. Mileage is around 48.
 

·
Registered
Joined
·
719 Posts
Over last few years it seems that everyone uses different settings on the Fi2000. I think the reason is due to several variables such as riding style, ambient temp, air density, altitude and air flow. There's many more variables but these are the most dominant. In an open loop fuel system there is no perfect set and forget setup. For drag racing we have a weather station in the trailer and use a computer to monitor all aspects of engine performance. The computer lets us make adjusts on the fly to keep the engine from becoming a grenade, same principle and ECMs in modern cars. On my 900 I still tinker with settings because useable fuel for riding at 30 degrees is different than 80 degrees.
 

·
Registered
Joined
·
89 Posts
After calling the Cobra techs and working with with my bike on a bunch of runs, i have found the 2-1-1 worked best for me. i have BAK and Road Runner 3" stepped dragsters. try moving the last pot to like 1.5 or 2, that should help your cruising acceleration.
 

·
Registered
Joined
·
719 Posts
Remove the secondary throttle plates; the problem isn't always fuel. Throttle response will be much improved but it does change the behavior of the engine and takes getting used to.
 

·
Registered
Joined
·
390 Posts
06 Vulcan 900 Classic

Ness Intake
Freedom Performance Sharp Curve Radius
Cobra FI2000R

Just installed pipes today settings are 2-2-1

Wondering if anyone else has my setup and what their settings may be?

 

·
Registered
Joined
·
390 Posts
I'm still running 2-2-1 but my neighbor said he could smell a little gas when he was riding behind me. But it has been running pretty good. Gas mileage maybe not up to par though.
 

·
Registered
Joined
·
182 Posts
I have Cobras speedster swept pipes with stock air cleaner, I' getting ready to instal the FI2000R, should I start with 221 suggested or should I leave it at420.
Next week I'm installing the Kuryakin Hypercharger, what should be the setting on that scenario?
 

·
Registered
Joined
·
390 Posts
I have Cobras speedster swept pipes with stock air cleaner, I' getting ready to instal the FI2000R, should I start with 221 suggested or should I leave it at420.
Next week I'm installing the Kuryakin Hypercharger, what should be the setting on that scenario?
My bike runs pretty good. But my riding partner can smell a little gas when I give it gas. lol Probably running a little rich at 2-2-1. But I have yet to adjust anything. I really want to get down to the kawasaki dealership and have them set it for me. I have to drive 240 miles roundtrip to the nearest dealership though so I haven't made it yet.

My advice is to start with 2-2-1. I called cobra and they recommended these settings.
 

·
Registered
Joined
·
182 Posts
That's the setting i have, and it pops like crazy, imcould say, it pops the same. I'm going to try factory setting to see how it goes.
Btw, I debaffled the pipes.
 

·
Registered
Joined
·
390 Posts
That's the setting i have, and it pops like crazy, imcould say, it pops the same. I'm going to try factory setting to see how it goes.
Btw, I debaffled the pipes.
You will have to marble your intake. I did and I get almost zero pops. I can't remember the last time I had a pop and I have rode 5 times this year for a total of 300 miles. The marbling works really well.

Let me find you the thread that discusses how to do it:



Here is me putting up some high rez photos of how I marbled mine. It's been the best thing I every did after installing my new pipes. I had the stage 3 full debaffle on my stock pipes before I bought my sharp curve radius pipes.

http://www.vulcanforums.com/forums/showthread.php?t=25687&page=4
 

·
Registered
Joined
·
182 Posts
Isn't that hose suppouse todosomething, if i marble it I'm mking that hose useless.
What's the deal with that.?
 
1 - 20 of 36 Posts
Top