Kawasaki Vulcan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Bros, first i need to thank you all for the great support most of the brothers here supported me with during the engine fail, now after 3 months of work and replacing parts the beast engine is back as new and i gave my bike the Army look with matte olive green.
Need your expertise with the vibrations, i am still easy on the engine and I don't rev it at all, kinda easy on all gears till 1K miles as per the mechanic recommendation, but still i can feel a good deal of vibrations in the bars even under 40m/hr and even on kick stand when you rev it a bit the bars vibrate noticeably!, its back now to the workshop to check the issue, any ideas ? Do the engine mounts suffer after time ? Or the rubber balancers ?



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,467 Posts
That looks great! For having such a distinctive headlight and big heavy front end, this bike lends itself to a stripped down look very well. Nice job.

What did you do with your front turn signals. I took my stock ones off to feature the headlight more, but I haven't found an application I'm happy with yet. Right now I've got some cheap bullet lights down where the fork reflectors used to be, but I'm always looking for a better way.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #4
That looks great! For having such a distinctive headlight and big heavy front end, this bike lends itself to a stripped down look very well. Nice job.

What did you do with your front turn signals. I took my stock ones off to feature the headlight more, but I haven't found an application I'm happy with yet. Right now I've got some cheap bullet lights down where the fork reflectors used to be, but I'm always looking for a better way.


Thanks bro for the feedback, actually I removed the front signals for more stripped look, i ll install new ones right on the Handel bar, hope they ll look nice


Sent from my iPhone using Tapatalk
 
1 - 5 of 5 Posts
Top