Kawasaki Vulcan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Has anyone had a minor coolant drip from under the engine on a 900 Classic? It is the occasionable drip. I have heard that it is common issue with Vulcans.
 

·
Registered
Joined
·
761 Posts
I had a coolant hose clamp under the gas tank need to be tightened but never a coolant drip under the engine.Have you checked the coolant reservoir tank on the lower left side of the bike?
 

·
Registered
Joined
·
761 Posts
No,did not need to remove the tank.Check the hose clamps using a flashlight to see better.You should see a crusty buildup if any have been seeping.
 

·
Registered
Joined
·
7,620 Posts
Hose clamps are a fairly common item on these 900's need tightening, as others have pointed out.

In my experience though, one should use a flashlight like Bandit said and check all over. Wind (which gets swirled around and might not be going the way you think) vibrations, etc., sling that stuff everywhere. Check things like the area around the filler cap for evidence of coolant seepage, all hose clamps, etc.
 

·
Registered
Joined
·
81 Posts
As others have said check your hose clamps under the tank - but use a socket you will never get em tight enough with a screwdriver.
 

·
Registered
Joined
·
117 Posts
I will chime in on the hose clamps also. Most of mine were leaking. Tried to tighten, but still had a small leaks. Finally, I just replaced them with some from the auto parts house. Haven't leaked since in 5 years.
 
1 - 7 of 7 Posts
Top