Kawasaki Vulcan Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Hey y'all, I just bought an 06 900 Classic LT last week and noticed that the low fuel warning light doesn't come on when you turn on the key. Bad bulb is my first guess. I'm sure I can get the chrome cover off, but how easy is the bulb to get to and is there a number on it. Thx for any help.
 

·
Registered
Joined
·
19 Posts
Are you sure it is supposed to come on? I have a brand new 2015 and the only lights that light up when you turn the key on are th FI and Oil lights. The FI light goes out and the Oil stays on until the bike is started.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
Yes, the manual says,"The fuel level indicator light goes on when the ignition key is turned "ON" and goes off soon after ensuring that the circuit funcitons properly." I'd like it to work also when the gas gets low. Been there, done that before. Thanks for you input. Ride safe.
 

·
Registered
Joined
·
761 Posts
The low fuel light does NOT come on when I turn my key on either.I have a 2016 model that I purchased new a couple of months ago.I think you are trying to fix something that is not broke.
 

·
Registered
Joined
·
19 Posts
Something must have changed on the newer models. The manual for the 2015 has the same wording as Wooz quotes but refers to the fuel injection, not fuel level, light.
 

·
Registered
Joined
·
761 Posts
Possible.We need someone with an older bike to check theirs and post up the results.I do not remember what my older 900's did as far as the low fuel light goes.
 

·
Registered
Joined
·
136 Posts
I have an 07 and the low fuel light does not come on when the bike is first turned on. The manual makes no mention of it either say the fi, oil pressure, and water temp light should come on then turn off after the key is first turned on to run bike diagnostic check.
 

·
Registered
Joined
·
136 Posts
Sorry should have read 200 because I get 250 miles to a
tank and I've done it 3 times in a row. Since I've put my new exhaust on I'm not sure what my milage is but I'm heavier on the throttle also lol
 

·
Registered
Joined
·
27 Posts
Discussion Starter #13
My manual also has a section for FI, but the sentence I quoted came from the low fuel level section. Thanks so much to all who took the time to reply. You help is much appreciated.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #14
06 classic,light did not come on when key turned on,only fi and oil
Hey revrider, thanks for the info. I won't fool with it. The general consensus is that the light isn't supposed to come on when the key is turned on, even though the manual says it should. Not a big deal as long as it comes on when the gas is low.
 

·
Registered
Joined
·
761 Posts
Hey revrider, thanks for the info. I won't fool with it. The general consensus is that the light isn't supposed to come on when the key is turned on, even though the manual says it should. Not a big deal as long as it comes on when the gas is low.
Run her low on gas and post back the result,I think the light will come on as designed to do.
 

·
Registered
Joined
·
633 Posts
Yep 2008 900 classic LT here, fuel light does not come on when you first turn the key , not even when you hit the start button, unless of course your gas is low! It seems like I have about 1 gallon left when the light first comes on
 

·
Registered
Joined
·
1,489 Posts
Yep 2008 900 classic LT here, fuel light does not come on when you first turn the key , not even when you hit the start button, unless of course your gas is low! It seems like I have about 1 gallon left when the light first comes on
Yup sounds bout right
 

·
Registered
Joined
·
27 Posts
Discussion Starter #19
Problem Resolved. I ran the bike low enough on gas to make the light come on. It came on at 180 miles. I filled up at 184 miles and took 3.5 gal. That comes to about 52 MPG averaging about 60-60 mph. (2 lanes, back roads) Hey, I'm really satisfied with the mileage and knowing that the light works as designed. I re-read the manual and it DOES say the low level light should come on with the ignition. Obviously, the manual is wrong, you guys were right and the light works. My next issue is to get the resistor fix to correct the gas gauge problem. Thanks guys, for all your helpful input.
 

·
Registered
Joined
·
1,489 Posts
Problem Resolved. I ran the bike low enough on gas to make the light come on. It came on at 180 miles. I filled up at 184 miles and took 3.5 gal. That comes to about 52 MPG averaging about 60-60 mph. (2 lanes, back roads) Hey, I'm really satisfied with the mileage and knowing that the light works as designed. I re-read the manual and it DOES say the low level light should come on with the ignition. Obviously, the manual is wrong, you guys were right and the light works. My next issue is to get the resistor fix to correct the gas gauge problem. Thanks guys, for all your helpful input.
wooohoo,told ya,have opposite problem w my nad,frkn gas lite is always blinkn,only gettn 33mpg but ahhhhhh the comfort:smile2::smile2:
 
1 - 20 of 25 Posts
Top