Kawasaki Vulcan Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I'm sure this is a simple answer but hoping for some help.

My rear-left turn signal is loose. I looked under the tail and there appears to be a clip or something to secure it. Unfortunately it was a bit dark out and I couldn't see clearly. Does anyone have insight on how to secure the clip correctly? Or are the pics online? I searched through the service manual and couldn't find clear instructions.
 

·
Registered
Joined
·
13 Posts
I'm sure this is a simple answer but hoping for some help.

My rear-left turn signal is loose. I looked under the tail and there appears to be a clip or something to secure it. Unfortunately it was a bit dark out and I couldn't see clearly. Does anyone have insight on how to secure the clip correctly? Or are the pics online? I searched through the service manual and couldn't find clear instructions.
 

·
Registered
Joined
·
13 Posts
No easy way to re-secure that plate without disassembling the rear fender. There's an inner lip on the inside of the light fixture. Put light back in hole then slide the back plate over b that
 

·
Registered
Joined
·
13 Posts
No easy way to re-secure that plate without disassembling the rear fender. There's an inner lip on the inside of the light fixture. Put light back in hole then slide the back plate over b that
Inner lip as best you can. It will hold. If it pops off again, just repeat. I'm getting a tail tidy kit to remove factory turn signals.
 

·
Registered
Joined
·
29 Posts
I'm sure this is a simple answer but hoping for some help.

My rear-left turn signal is loose. I looked under the tail and there appears to be a clip or something to secure it. Unfortunately it was a bit dark out and I couldn't see clearly. Does anyone have insight on how to secure the clip correctly? Or are the pics online? I searched through the service manual and couldn't find clear instructions.
This happened to me a few weeks ago. Very simple to fix. There is a metal bracket fastener with a screw. you have to undo the screw, push the bracket back into the rubber and then screw them both back in place. Then pop the light back in and it should be fine. I think it is built like this so if it gets knocked off, it can easily be put back in.
 

·
Registered
Joined
·
63 Posts
This happened to me a few weeks ago. Very simple to fix. There is a metal bracket fastener with a screw. you have to undo the screw, push the bracket back into the rubber and then screw them both back in place. Then pop the light back in and it should be fine. I think it is built like this so if it gets knocked off, it can easily be put back in.
My left turn signal also got "Loose",after re-assembling it numerous times,I finally got some of the caulking to hold auto wind:unsure:o_O:cool::geek:sheilds in place&Just caulk'd around it-Looks Goofy/But holds in place now:)
 

·
Registered
Joined
·
29 Posts
My left turn signal also got "Loose",after re-assembling it numerous times,I finally got some of the caulking to hold auto wind:unsure:o_O:cool::geek:sheilds in place&Just caulk'd around it-Looks Goofy/But holds in place now:)
Whatever works my friend! Ever since I put mine back in place, it hasn't gotten loose again. Ride safe!
 
1 - 9 of 9 Posts
Top