Kawasaki Vulcan Forum banner
1 - 20 of 24 Posts

·
Registered
2009 Kawasaki Vulcan 900
Joined
·
10 Posts
Discussion Starter · #1 · (Edited)
Hello Friends, I recently changed my rear taillight to LED and I just changed my front turn signals to LED on my 2009 Kawasaki Vulcan 900. I am having an issue that I can’t seem to find on other discussions. So any input would be a help! I replaced my rear taillight with a Bike Master Intergrated LED taillight kit which came with the flasher relay so that corrected that problem. I just received my two 1157 switchback LED Bulb and installed them. I turned the turn signal on and the fronts switched from white to solid amber, not flashing, and the taillight was flashing both right and left signals acting like hazards are on. I have ordered a few flasher relays but not sure if that will correct this issue. I really don’t want to tear apart my cluster in order to correct this so maybe a load resistor? Seems dumb to have to add that when trying to reduce the load. Any thoughts on this?
 

·
Registered
Joined
·
438 Posts
I did not install and aftermarket light assemblies on my bike but I replaced all the bulbs with LED equivalents. The first electronic relay I bought to replace the stock one (EP34) did not work right even though it was tagged as replacement for EP34 Which one came with the tailight kit? The symptoms you’re describing sound like that could be the problem. Especially if you didn’t change wiring.
 

·
Registered
2009 Kawasaki Vulcan 900
Joined
·
10 Posts
Discussion Starter · #3 ·
I did not install and aftermarket light assemblies on my bike but I replaced all the bulbs with LED equivalents. The first electronic relay I bought to replace the stock one (EP34) did not work right even though it was tagged as replacement for EP34 Which one came with the tailight kit? The symptoms you’re describing sound like that could be the problem. Especially if you didn’t change wiring.
Mmart, when I originally replaced the taillight with the Bike Master kit it came with the flasher relay because it was hyper flashing after install. The kit is basically plug and play, you just have to solder the turn signal wiring in. I believe that is the EP34 and located in the front of the battery housing? I purchased another flasher relay and a LF1-S-PIN. I am think either one of those will work. Do you have a part number for the relay or where you purchased the relay from? Thank you for the reply!
 

·
Registered
Joined
·
438 Posts

·
Registered
2009 Kawasaki Vulcan 900
Joined
·
10 Posts
Discussion Starter · #5 ·
Here’s what ordered:

Dewhel 1 pc CF-13 CF13 EP34 3 Pin Electronic Flasher Fix 12V 0.02A-20A For LED Turn Signal Light Bulbs Hyper Blink Flash No Flash https://www.amazon.com/dp/B0786CX8L...abc_671ASJKWH73N8J2XSWCA?_encoding=UTF8&psc=1

Note when you look at the pick the flasher say “CF13 JL-02”, there is also a “CF-13 GL-02”. The JL model is for Japanese vehicles. The GL is for European.
Here’s what ordered:

Dewhel 1 pc CF-13 CF13 EP34 3 Pin Electronic Flasher Fix 12V 0.02A-20A For LED Turn Signal Light Bulbs Hyper Blink Flash No Flash https://www.amazon.com/dp/B0786CX8L...abc_671ASJKWH73N8J2XSWCA?_encoding=UTF8&psc=1

Note when you look at the pick the flasher say “CF13 JL-02”, there is also a “CF-13 GL-02”. The JL model is for Japanese vehicles. The GL is for European.
Hello Mmart do you remember where this plugs into? The only relay I have found is a two pin in front of the battery
 

·
Registered
'05 800B
Joined
·
2,238 Posts
you're not going to like what i say here, but leave your lights alone, just change out the rear 1157 bulbs to 2357 bulbs, that's it, leave all your other lights and turn signals alone
 
  • Like
Reactions: Casey6404

·
Registered
2009 Kawasaki Vulcan 900
Joined
·
10 Posts
Discussion Starter · #7 ·
you're not going to like what i say here, but leave your lights alone, just change out the rear 1157 bulbs to 2357 bulbs, that's it, leave all your other lights and turn signals alone
Btom, we are all able to have our own opinions and it may be that I change the front back but we shall see because I want to have all LED lights. Have my full LED headlight on it’s way here so I am committed just need to figure out what to do next. I appreciate the thought.
 

·
Super Moderator
Joined
·
948 Posts
Just curious. What's the hype about an LED bulb hidden behind a red or yellow plastic lens? I get headlights, light bars, etc but never understood doing it to turn signals or brake lights. It's barely noticeable.
 

·
Registered
'05 800B
Joined
·
2,238 Posts
he's messing around installing LED lights then wonders why there's a problem, the problem is with LED lights, solution is simple, put back the lights you had in the beginning, problem solved
 

·
Registered
2009 Kawasaki Vulcan 900
Joined
·
10 Posts
Discussion Starter · #12 ·
Just curious. What's the hype about an LED bulb hidden behind a red or yellow plastic lens? I get headlights, light bars, etc but never understood doing it to turn signals or brake lights. It's barely noticeable.
The rear lens is tinted smoke so it is very noticeable. I also changed the front lens to clear and it is very noticeable
 

·
Registered
2009 Kawasaki Vulcan 900
Joined
·
10 Posts
Discussion Starter · #14 ·
he's messing around installing LED lights then wonders why there's a problem, the problem is with LED lights, solution is simple, put back the lights you had in the beginning, problem solved
Hey man I came to the forum for advice or help on if this issue had been corrected in the past. LEDs are the way of the future my friend so if you want to live in the past that’s your choice. Anyway have a great day.
 

·
Registered
2009 Kawasaki Vulcan 900
Joined
·
10 Posts
Discussion Starter · #17 ·
Got it, I read back and see you have a 900. So, My thought is something wonky with the flasher but if it's only 2 pins I'd expect it to either flash or not flash, not for the rear to flash and the front be solid.
That was my thought. I did unplug the instrument cluster to see if that would work and it didn’t really so I am thinking it might just take more research and maybe a load capacitor or something to fix it
 

·
Registered
2009 Kawasaki Vulcan 900
Joined
·
10 Posts
Discussion Starter · #19 ·
"Load Resistors" I'm sure you meant ;) There's some info on Gadget's page Switching to LED Turn Signals though not so much on the integrated taillight. If you have one turn indicator the load resistor setup is a little more complicated since without diodes it can feed current from one side to the other through the indicator.
Yes load resistor is what I meant. Thanks for the website I’ll take a look at it!
 

·
Registered
Joined
·
512 Posts
Just curious. What's the hype about an LED bulb hidden behind a red or yellow plastic lens? I get headlights, light bars, etc but never understood doing it to turn signals or brake lights. It's barely noticeable.
LEDs use way less power so if you're 'scavenging' power so that you can run a heated vest or gloves or grips or ??? LED's will help with that. And depending on qulity, the LEDs will probably outlast the bike by a fair margin (admittedly, where to get quality Led is another issue though)
 
1 - 20 of 24 Posts
Top