Kawasaki Vulcan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
I have for sale:
A used Cobra Fi2000R Fuel Processor/EFI Tuner part #92-1963 for a Kawasaki Vulcan Nomad 1600. This processor came off a 2008 and was used for 1 season. (please check the part number to see if it will fit your bike at www.cobrausa.com )(this part may fit multiple bikes)

The unit is in good condition and is ready to be installed on your bike!! It is a very simple installation and makes a noticeable difference in the performance of your bike if you have made any air or exhaust changes. The instructions are included in the box.

The only thing that was changed on this unit was the ground wire. It was lengthened to reach the battery for the ability to direct ground instead of grounding to the frame. The joint is neatly done - shrink wrapped - and wrapped with electrical tape.

The 3 adjustable 'pods' are still set on the factory settings. There are instructions on how to adjust them if you would like..

Pick up this processor for your bike at a huge savings vs new...list price is over 200.00......

Item sold as is...no warranties or returns.

Item shipped USPS Priority Mail

Asking $125.00 OBO
Prefer Paypal for payment.
 

Attachments

·
Registered
Joined
·
111 Posts
May i ask why you got rid of your cobra fuel management system? I have the power commander 3. Can't help but wonder if I made the right choice.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #4
Reply

Well I have a 08 1600 nomad.
My bike has no aftermarket parts as to exhaust or air intake.
When i put the cobra efi on I notice that the bike when decelerating would hang just a little bit around 2000 rpm causing me to brake a little harder then I was comfortable with.
But since taking it off I notice that my bike would run irractic as far as throttle.
Well anyway to make a long story short I install the resister fix (http://www.gadgetjq.com/ping_fix.htm).
In the process of doing this mod I inadvertent let two rubber hoses to the air intake loose and they came off.
I believe this is where my problem was and not the cobra efi.
I do not have it any more to try it but I will say one thing my 3 and 4th gear had all sorts of pull and acceleration.
Kinda miss it but after doing the above resistor mod I am it seems achieving the same thing.
I would suggest reading my thread I had going (http://www.vulcanforums.com/forums/showthread.php?t=22641) to read what I learn from another gentleman.
In the end I am staying with the mod especially in light of the mistake in the hoses.
Everthing is running normal now and I change the values of the resistor as mention in the thread I mention below.
I hope this answer your question if not you are more and welcome to email me.

Regards and safe travels.
Dave
 
1 - 4 of 4 Posts
Top