Kawasaki Vulcan Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Vulcan 900 with Cobra speedsters didn't really have any popping before. It gradually developed a decel popping especially when cold. Now it sometimes pops when warm depending on air temperature, sometimes when upshifting. It's been gradually increasing over the last 10k miles. Almost 40k on the clock now. The other night, my friend said there was a bit of flame in the pipe when it popped at night. These are stock straight-through baffles.

It has new exhaust gaskets since the clutch was replaced. No change at all. Valves have been checked twice and they're mostly on the looser side within spec. Any other ideas what would cause this? I don't mind the noise, but it bothers me that it seems to be increasing over time.
 

·
Registered
Joined
·
3 Posts
Vulcan 900 with Cobra speedsters didn't really have any popping before. It gradually developed a decel popping especially when cold. Now it sometimes pops when warm depending on air temperature, sometimes when upshifting. It's been gradually increasing over the last 10k miles. Almost 40k on the clock now. The other night, my friend said there was a bit of flame in the pipe when it popped at night. These are stock straight-through baffles.

It has new exhaust gaskets since the clutch was replaced. No change at all. Valves have been checked twice and they're mostly on the looser side within spec. Any other ideas what would cause this? I don't mind the noise, but it bothers me that it seems to be increasing over time.
Keeps it, shoos flaymes
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #4 ·
When is the last time you changed your plugs? Does it have any kind of fuel controller or tuner on it?
Plugs are fine. Fueling is stock. No controller necessary for just the pipes with stock intake. In fact, it ran better without the Power Commander. I may try synchronizing the throttle bodies again.
 
1 - 4 of 4 Posts
Top