Kawasaki Vulcan Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
VN900 Classic 2007 - 11481 miles.

After all works with manual the second cylinder is knocking. Warm or hot it's the same.
What to do?
 

·
Registered
Joined
·
722 Posts
I would start by removing the valve covers and checking from there. It sounds like a valve train issue. It's interesting that it still seems to idle ok. Did a valve shim come out, causing the knocking noise?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I would start by removing the valve covers and checking from there. It sounds like a valve train issue. It's interesting that it still seems to idle ok. Did a valve shim come out, causing the knocking noise?
Don't think so. We checked many times and do everything with the manual, but it's still knocking
 

·
Registered
Joined
·
722 Posts
Ok. My next thought was be maybe a loose wrist pin, or piston slap. But it doesn't exactly sound like either of those. The next thing I noticed was that the knock sound is much sharper on the right side than on the left. That leads me to believe there could be a burned exhaust valve on the right side (of the 4 valve head). Can you do a compression test on both cylinders, and report back with your findings?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Ok. My next thought was be maybe a loose wrist pin, or piston slap. But it doesn't exactly sound like either of those. The next thing I noticed was that the knock sound is much sharper on the right side than on the left. That leads me to believe there could be a burned exhaust valve on the right side (of the 4 valve head). Can you do a compression test on both cylinders, and report back with your findings?
ok, i'll ask about it! thanx a lot, bro
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
The problem was that the second cylinder was not working. This is done.
Ride, washed. In the morning they started the motorcycle, it started to get hot and stalled. Twists, but won't start
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9 (Edited by Moderator)
Exactly. They said that the second cylinder was not working cuz of spark plug. Cleaned the spark plug and he started without knocking. When i came to take him back. He worked for 1-2 minutes and stalled. Tired of this crap. Whole summer i just waiting and waiting.
 

·
Registered
Joined
·
722 Posts
I;m glad you found the issue and I'm glad that's all it was. The vulcan 900 has a pretty robust engine, glad to see all is ok with your bike.
 
1 - 11 of 11 Posts
Top