Kawasaki Vulcan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,493 Posts
Discussion Starter #1
I am Having trouble getting the headlight plug off,Don't have a ton of room,tried wiggling it ,just doesn't want to budge,any tricks or suggestions?Have to replace the lens and bulb,without breaking anything:frown2:
 

·
Registered
Joined
·
1,188 Posts
don't break it, just keep on wiggling up and down then left and right, it should come, be patient
 

·
Registered
Joined
·
1,493 Posts
Discussion Starter #3
don't break it, just keep on wiggling up and down then left and right, it should come, be patient
Patient? me??not one of my traits but will do.plug and wires look good ,no burns that I can c,will keep workn on it,took batt out just in case,Nothin i can put under to pry it up???or better to keep wigglin,,hate electronics
 

·
Registered
Joined
·
1,493 Posts
Discussion Starter #4
Spent 45 minutes on the plug tonite,just won't come off,any other thoughts,am I missing a tab??just shouldn't be this difficult,Ready to take it to the shop
 

·
Registered
Joined
·
34 Posts
Rev, if you have another set of hands there have them hold the light while using both of your hands to work the headlight bulb connector off. If that doesn't work with your assistant holding the light carefully use a screwdriver to slowly pry the connector a little bit at a time on each prong. All the best.
 

·
Registered
Joined
·
1,493 Posts
Discussion Starter #6
Rev, if you have another set of hands there have them hold the light while using both of your hands to work the headlight bulb connector off. If that doesn't work with your assistant holding the light carefully use a screwdriver to slowly pry the connector a little bit at a time on each prong. All the best.
Yea,will try that thanks,Don't want to get too aggressive w it,thought maybe there was a tab but don't think so,will keep tryn,,,,,Damn did sway bar links on my truck faster than changin this light,thanx:surprise:
 

·
Registered
Joined
·
324 Posts
I had my headlamp off once and don't remember having to do anything unusual.

Giving a little pry at each terminal may do the trick or at least expose the problem.
 

·
Registered
Joined
·
1,493 Posts
Discussion Starter #8
Problem solved,Got fed up,took it to my shop,He changed out the MELTED Plug and lens housing,inspected it ,40 bucks,,,,lesson learned bout 100w bulbs on a stock configuration ,was a nice bright light tho,charging system checked out ok
 
1 - 8 of 8 Posts
Top