Kawasaki Vulcan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2005 v2000 with 5937 miles. I just went to
ride and had big time problems with the engine choking out
(almost stalling) when I cranked the throttle. It also stalled
a couple times. I was able to get it running enough to top off
the gas tank at a station about 4 miles down the road then got
back home. It would sometimes accelerate normally, then
would start to stall out. It will sometimes rev high, and other
times flutter out.

I'll be seeing my dealer but would like a heads up on
what may be wrong.

Is it possible I have bad gas or does this sound like
a problem with the Fuel Injector.

The last time I ran the machine about 3 weeks ago
there was no such problem. The bike is always
kept in doors, is dry and it hasn't been run much this
year because of the rain.

Any thoughts on what this problem may be.

Thanks

TimK.
 

·
Registered
Joined
·
240 Posts
Check your battery posts to see if they're "clean" and tight. Loose connections can cause all kinds of wierd things. I'd drain the tank , add new fuel (from a different gas station!) and add 5 or 6 ounces of Seafoam, then run the bike.
 

·
Registered
Joined
·
9 Posts
Sounds like the fuel pump. The fuel pump and filter are located in the gas tank, as a single unit. Let me know what you find out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
FI Problem or bad gas.

I went the easiest route and siphoned as much gas as I
could and replaced about 4.2 gallons with about 6-8 oz of
Sea Foam. That appears to have done the trick. I drove it
about 25 miles and although I still have a bit of hesitation
sometimes in the first 1/8th of the throttle, the acceleration
after that seems to be crisp. When I rev from idle with no
load, it seems to be as responsive as should be. I'm assuming
that after another tankful, I should be ok.

Even before the fuel change, the idle seemed to be ok. It
fluttered and started to stall when I either revved from
idle or accellerated under load. I'll post another message
if the hesitation does not go away.

Thanks
timk
 
1 - 5 of 5 Posts
Top