Kawasaki Vulcan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
251 Posts
Discussion Starter #1
I have a 2005 1600 Nomad. 33,000 miles. I use premium fuel. I noticed a pinging last year before putting the bike away for the winter. Running 70-75 mph I crack the throttle to pass and the pinging starts. If I drop to 4th and the ping goes away. I will be getting the bike out of storage in a few weeks and taking it to the dealer for service. Any suggestions on what I should have them look at regarding the ping. Bike is stock, no add ons.
I plan on having them put in new plugs (iridium), change the oil, coolant and final drive oil.

If you have any ideas I would appreciate them. I had retina surgery in March, and the Dr. Should clear me to ride in early June. So I have time to research this issue.
 

·
Registered
Joined
·
3 Posts
I would change the plugs, add some Seafoam to the gas for a couple of tanks and see how that works out.
I agree, except I would use something a little better than sea foam, if you can get your hands on some BG 44K, give it a shot. It not only cleans the carbon out, but will clean the injectors and any O2 you may have. That is the stuff professionals use. Be careful with the iridium plugs, that could also be part of your problem, check with the manufacturer for what type plug they use. I believe they are double platinum, I could be wrong. Reason being is the higher end plugs give off a hotter spark which could be at least partially to blame for your detonation.
 

·
BOTM Winner, December 2016
Joined
·
326 Posts
Visit the Vulcan gadget web site...

There are 2 fixits listed...
I did the "resistor mod"...

Ride on !!!
Luckymann77
 
1 - 5 of 5 Posts
Top