Kawasaki Vulcan Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 ·
Well,*[email protected],000 miles w/my ol dog/Now the doggone code 21-Engine crankshaft sensor goin bad/*Hopefully it's just a short somewher_*Hopefully:( Poor ol dog's been makin a "Clickin sound for about the past3weeks everytime I try to start it/'even had to 'bump start it tonight after work-Hoprfully its just a short somewhere in the wiring\Any 1 w/this [email protected] this mileage w/the crank sensor,it would Certainly be appreciated on any advice. Going to let 1 of my techs take a [email protected] tomorrow...... I was really hopin to roll the [email protected],000 before this years end-BUT NOT LIKE THIS.....:unsure:o_O:censored:
 

·
Registered
Joined
·
26 Posts
Sounds like you have either a bad battery or bad ground. Start with the simple stuff. I would check all the battery connection first. If all good then replace the battery and see if the code clears. If it still won't clear then replace the sensor.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #3 ·
Sounds like you have either a bad battery or bad ground. Start with the simple stuff. I would check all the battery connection first. If all good then replace the battery and see if the code clears. If it still won't clear then replace the sensor.
Battery was replaced not long ago/is the sensor hard to replace?
 

·
Registered
2017 Vulcan 900 Classic
Joined
·
766 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #5 ·
A good reason to double check the connections. I had some codes and it ended up being both of my battery connections had come loose.

Anyway, doesn't look difficult - but I have no idea what your skill level is.

Here's the service manual:
Thanks for the advice my "electric skill levels stink-going to let 1 of my local techs check out all bikes ground & electric connections/ of course the dealership is saying that the crankshaft sensor is $700 because it is part of the throttle body:(-Hopefully just a bad connection somewhere..
..:eek::cool:o_O:rolleyes:
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #6 ·
Poor ol dog just couldn't make 40,000 MILES before the holidays without a brain fart:ROFLMAO::unsure:
Thanks for the advice my "electric skill levels stink-going to let 1 of my local techs check out all bikes ground & electric connections/ of course the dealership is saying that the crankshaft sensor is $700 because it is part of the throttle body:(-Hopefully just a bad connection somewhere..
..:eek::cool:o_O:rolleyes:
The 3 ride code clearing worked:) Still gotta replace the starter relay&Check All the connection's out;)(y):cool::love:
 
1 - 6 of 6 Posts
Top