Kawasaki Vulcan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
maybe someone has had this problem my bike just died no lights horn etc just wont say anything checked fuses change battery what could it be have no clue help vulcan 2000
 

·
Registered
Joined
·
59 Posts
Your ground could be corroded or lose. But I really think your problem is the battery. The battery could read 12 volts, but not have the cranking amps required to turn the starter.
 

·
Premium Member
Joined
·
2,444 Posts
First thing I would check is kill switch. Then I would check that all the cables are tight. I'm not sure if it would cause you lo loose all power but I would also check the starter relay.
 

·
Registered
Joined
·
53 Posts
same issue

about a month ago i came out from docs office got on the bike and turn the key nothing at all i checked everything not luck trailered it home started to take covers off used a meter found power going all the way to the igition switch but stopped right there so i thought it was a faulty switch tried to unplug the switch and for the life of me the darn thing would come apart
other plug the same style would but not this one after some butcher work by me two peers of vise grips i pulled on the plug as i did i forgot that the key was on and everything came on you know the fuel ejector and the lites
some how it shorted out and one pin in the plug got hot enough to melt a little bit of plastic sorry for the long story i get carried away sometimes ------- so check your igition switch tommyj
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
eletric problems

thanks guys for all the advise there was one fuse i took everything appart and it was a fuse on top of the battery terminal sorry took so long to reply couldn't remember my password
 

·
Registered
Joined
·
60 Posts
Bet you won't forget where that one is, will you? Glad you found it, only thing worse than a broke bike is one that you can't figure out.

Now go ride it.
 
1 - 7 of 7 Posts
Top