Kawasaki Vulcan Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
Hello to all riders, I have a 08 900 classic Lt., Roadhouse pipes, Power Commander, and had Dynoed. Ran perfect for aprox. 6,000 mi., now every time I let off the gas it backfires Really Bad and when clutched it either dies or idles like a sick harley.Checked for loose wires at battery(ok) checked to see if any leakes arround pipes(no). Checked with dealer, they said they would have to try a few different things to fig. it out( and we all know that means $$$$) Any info. about this would Really help before I have to take to dealer. Do power commanders go bad? It started this on my last ride and done it for aprox. 125mi. back home, could I have hurt my motor?,,Thanks for any help and...Ride Safe
 

·
Registered
Joined
·
711 Posts
Fuel managements rearly go bad. Bike been off idle could be the air valve by the airbox. About the back fire you could try to minimize it by marbeling but won't fully get ride of the problem.
 

·
Registered
Joined
·
950 Posts
You probably already did this, but I would first check the air tubes running your PAIR system. Sometimes they come loose.

I would also remove the PC and see if the bike runs better. If it runs better, hook it back up. If bike runs crappy agin, you have isolated the fault.
 

·
Premium Member
Joined
·
1,130 Posts
Do the easy checks first. Inspect the spark plugs to see how each cylinder is running.
DynoJet used to supply "vampire clips" to make the connections to the PCIII easier to the OEM wiring and they cause nothing but trouble. They can loosen or they can cut through the OEM wiring. It is best to solder these connections. Inspect the connection at the TPS closely.
Fuel managers do go bad so you can disconnect the plugs at the injectors and go back to stock. No need to disconnect anything else.
Do you notice a smell of gas or a rich smelling exhaust when the engine is running?
Is your FI warning light flashing any codes?
Since it happened suddenly, think back to anything that happened at that time. Maybe a bad batch of fuel?
 

·
Registered
Joined
·
62 Posts
Discussion Starter #6
Help with backfiring

Thanks folks for the info. sofar,,,I didn't check the air hoses, but I will first chance I get and I'll let ya know what I find,,,Thanks again from Tennessee...and i'll ck. the air filter too.
 

·
Registered
Joined
·
62 Posts
Discussion Starter #7
Hi, and Thanks..no I don't smell any fuel at anytimeand the FI light is not blinking, I will check the PC connections to see if loose, but if I disconect PC, won't I have to have it remaped for it to operate right,,,,Thanks
 

·
Registered
Joined
·
950 Posts
Hi, and Thanks..no I don't smell any fuel at anytimeand the FI light is not blinking, I will check the PC connections to see if loose, but if I disconect PC, won't I have to have it remaped for it to operate right,,,,Thanks
No, the software does not dump just because you disconnect it. The settings stay until changed.
 

·
Registered
Joined
·
63 Posts
check the nuts on your exhaust pipe

i was backfiring really bad, a couple of days later i found out that i was missing a few nuts on the exhaust that connect to the motor
 
1 - 11 of 11 Posts
Top