Kawasaki Vulcan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I think I've fried my clutch? Ive only done 1500kms? My friend rode my bike (we swapped bikes for a week) and a week later after going on a short ride it stalled at slow speed. I didnt ride after swapping back. I dont know if he was attempting a burnout or meesing around when he had it or there is something up with the bike from factory???

The bike is un-rideable atm. When it is in gear and off, when i pull the clutch in it doesnt disengage and you cant rock the bike back and forth. When you turn it on the bike creeps forward in first gear with clutch lever fully engaged until it eventually stalls.

Im so pissed! Please anybody help??? Whats the retail pn a replacement clutch? ?? Being a new bike i cant even find it online anywhere?

Please help!
 

·
Registered
Joined
·
713 Posts
Check your clutch cable hasnt just stretched over time. I just clocked over 3500km and was able to adjust at the lever in under 60 seconds.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Thanks a lot! Im in the process of finding a mechanic. Being a new bike and all. Hopefully its just the friction plates or the springs...

Thanks again for the link
 

·
Registered
Joined
·
2,221 Posts
Before going to a mechanic you REALLY should do as Cpt E said; and check your adjustment.

Creeping forward in gear means that it is working at least partially.
Look online and find a tutorial on adjusting your clutch lever; they are all pretty much the same.

Also, I would ask my buddy if he messed around with it at all. You don't have to be accusatory just make sure he didn't turn a knob or two.

Scott
 
1 - 6 of 6 Posts
Top