Kawasaki Vulcan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Clutch fluid is really nasty looking Rust and sludge in bottom of reservoir I plan to flush it and bleed it with new DOT4 fluid...can the crappy clutch fluid make the clutch act good sometime and crappy others? I know this is a dumb question. I bought the Bike used. the clutch engages at the end of handle release. ans sometimes will grind 2/3rd upshift or down.don't seem to be slipping maybe a little in high gear. I dont have a vac but hope to bleed it like a old brake system and make sure it dont get low during bleeding.
 

·
Registered
Joined
·
436 Posts
I think old/bad fluid can cause these symptoms. Especially if there's an air bubble in there. You should be able to bleed it just like a brake. Just use the bleed fitting down at the slave cylinder. You can also adjust the lever to get the engagement point where you like it.
 

·
Registered
Joined
·
23 Posts
You said you thought it might be slipping in high gear? Sounds like weak clutch spring. Just changed my clutch on my 1600! You can try to bleed might help? Go to harbor freight and get a vacuum brake bleeder $25!
 

·
Registered
Joined
·
11 Posts
This is on a 97 1500d classic
I got a D1..just fitted a new clutch..just bleed it as normal and see what happens. Could be a little bit of crap or air bubble..if i was doing it i would bleed it dry and remove the reservoir to clean it properly..its not a big job.
 
1 - 5 of 5 Posts
Top