Kawasaki Vulcan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Just picked up this 08 - custom with just @ 10k on it.
Started going over a few things and WOW - only two strand holding the clutch cable in place - so open to recommendations on a good new cable !!!
Good thing I was in no hurry to go riding !!!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Going with the Barrett stainless Steel - I sure don't need to have a surprise cable snap !!
Looking at setting the adjustment - wow three locations hey !!!
Sound like a touchy clutch set up !!!
Will see how I do - I didn't know about the setup in the middle of the cable !! Hope the new one is the right thing !!!
 

·
Registered
Joined
·
110 Posts
when i had my magna - i was down at the university for a function with the kids.
on the way home, I get off campus to the main road, and sit at a light. when i goes green, I go to take off and get about .5 seconds of throttle - then nothing. snapped the throttle cable - its a bad feeling.

good find on your part though
 

·
Registered
Joined
·
1,034 Posts
Just picked up this 08 - custom with just @ 10k on it.
Started going over a few things and WOW - only two strand holding the clutch cable in place - so open to recommendations on a good new cable !!!
Good thing I was in no hurry to go riding !!!
When you get your new cable, to prevent the same problem from occurring again, suggest that it be kept lubed. In nearly 50 years of riding I've never had to replace a clutch cable nor had it break off cable strands. I always keep cables lubed, especially at the clutch handle and cable sheath entry point.
 
1 - 5 of 5 Posts
Top