Kawasaki Vulcan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
Has anyone had a problem with their exhaust gaskets leaking and causing a loud chirp? Since I put the new Cobra pipes on I installed new crush gaskets and after about a thousand miles they started leaking. I retorqued them and all was good for a while. Now I'm getting the chirp back again.
Got to order a new set tomorrow I guess and put up with the bird until they get here.
 

·
Registered
Joined
·
987 Posts
gas leak

I put V&H pipes on my 04 and had a bit of problem with exhaust leakage, but I loosened ALL the mounting bolts, flange bolts, heat shield clamps etc, and then retorqued from the engine back. No more problem for 6 years....:cool:

I also have a 900C that I put a Cobra 2into1 pipe on. I found the fitment of the Cobra pipes to be rougher than the V&H, so it took a bit more screwing around with the mounts, flanges etc to get the leaks to stop, but they are stopped.

Even though the aftermarket equipment has fairly good quality control during manufacture, when we add it we should still do it like it is a custom application.:D
 

·
Registered
Joined
·
60 Posts
Discussion Starter #6
I put V&H pipes on my 04 and had a bit of problem with exhaust leakage, but I loosened ALL the mounting bolts, flange bolts, heat shield clamps etc, and then retorqued from the engine back. No more problem for 6 years....:cool:

I also have a 900C that I put a Cobra 2into1 pipe on. I found the fitment of the Cobra pipes to be rougher than the V&H, so it took a bit more screwing around with the mounts, flanges etc to get the leaks to stop, but they are stopped.

Even though the aftermarket equipment has fairly good quality control during manufacture, when we add it we should still do it like it is a custom application.:D
I like your advice. It's something I did not think of and I will be doing it like you suggest.
Thank you.
 
1 - 6 of 6 Posts
Top