Kawasaki Vulcan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
281 Posts
Discussion Starter #1
I am installing the PCV with ignition and want to make sure I have the coils wired properly. The instructions are the worst. Right side coil I matched red wires with the stock red and green. Then the green wires from the PCV to the black wire. Only wires left were the blue which i crossed to the other side and hooked them up to the black and orange wire. The stock red and green stayed on the left coil. Is that right? There are no more wires.

:confused:
 

·
Premium Member
Joined
·
2,115 Posts
It's been years since I did it. Let me find the instructions and see what I can remember.
 

·
Premium Member
Joined
·
2,115 Posts
Yes I believe that's right.

What are you going to do for a map?
 

·
Registered
Joined
·
281 Posts
Discussion Starter #4
:nerd:
It's been years since I did it. Let me find the instructions and see what I can remember.
I am pretty sure I did it right. Those instructions suck balls. I loaded your map and took it for a short spin. Nothing blew up. The bike feels like it has more pep but I need more saddle time. So far I only heard a small muffled pop at 2100 rpm. Ican bump the fuel at zero throttle another 4 or 5 in that column.

I did notice the idle seems to search a bit more when cold. After warm up she is fine.
 

·
Premium Member
Joined
·
2,115 Posts
That's great. Your doing it right.
I do remember I had some douts when I installed mine.
Keep in touch.
 
1 - 5 of 5 Posts
Top