Kawasaki Vulcan Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter #1
A couple of weeks ago I came out and found a drip of anti freeze about the size of a quarter on the driveway under my bike (08 900 lt) could not find any trace of where it may be leaking from. Checked my anti-freeze it was OK rode to work no problems ,rode for 2 weeks with a long ride thrown in, then I came out this morning once again a small drip .Anyone know where I may find a leak? Thanks
 

·
Registered
Joined
·
75 Posts
A couple of weeks ago I came out and found a drip of anti freeze about the size of a quarter on the driveway under my bike (08 900 lt) could not find any trace of where it may be leaking from. Checked my anti-freeze it was OK rode to work no problems ,rode for 2 weeks with a long ride thrown in, then I came out this morning once again a small drip .Anyone know where I may find a leak? Thanks
I have an 09 Custom and I had a problem with leaks at the hose connections on the top of the motor where the hoses were clamped onto the fittings going into the cylinders. Tightening the clamps helped but didn't cure it all together. I wound up replacing a short section of hose with the OEM factory formed piece and new clamps. In my case I noticed a white film showing up on the fins on the cylinders. I don't know if this is what's happening in your situation or not but I've been told it wasn't that uncommon. Hope this is of some help to you. RIDE SAFE.
 

·
Registered
Joined
·
224 Posts
If you look directly under the motor,more towards the right side...you'll see a small hole about 1/8" in diameter. I call it the "weep hole" and it's related to the water pump. I had the mechanical seal replaced in mine when it was doing that,and it still does it from time to time. More so when it's real hot out or I have been running it hard. Since I had my mechanic replace the mechanical seal,and it still does it now and then I havn't worried about it since it's not even enough to form a big enough drip to drop off...just runs out the hole a bit then dries up.
 

·
Registered
Joined
·
427 Posts
If you look directly under the motor,more towards the right side...you'll see a small hole about 1/8" in diameter. I call it the "weep hole" and it's related to the water pump. I had the mechanical seal replaced in mine when it was doing that,and it still does it from time to time. More so when it's real hot out or I have been running it hard. Since I had my mechanic replace the mechanical seal,and it still does it now and then I havn't worried about it since it's not even enough to form a big enough drip to drop off...just runs out the hole a bit then dries up.
Mine does the same...like you, too, though, never had enough for a drop to hit the ground.

Right side:



Left side:

 

·
Registered
Joined
·
130 Posts
Discussion Starter #6
Hey RTL, I checked out the area you replied about and that is exactly where the leak is coming from.Unfortunately for me, it is leaving a small drip on the driveway. Was it expensive to get this seal replaced.
 

·
Registered
Joined
·
224 Posts
My mechanic runs his own shop,so it was cheaper than a dealer,Apparently you have to drain the oil and antifreeze out to replace the seal. The cost of the seal was under $20.00 but it's the labor,new oil and antifreeze that gets ya. Since I bought all the materials/fluids and brought them to him,I think the labor was around $100.00 to replace the seal if I remember correctly.Like I said, the antifreeze still comes out a bit from time to time,but not like it used to. My mechanic told me not to worry about it to begin with since I never really seemed to notice a loss in antifreeze from the reservoir tank,but I can be a little anal when it comes to maintaining things on my bike,lol
 

·
Registered
Joined
·
537 Posts
Remember that these water pumps DO NOT like SILICATE in the coolant, it is abrasive and will devour the ceramic seal in pump.
 

·
Registered
Joined
·
224 Posts
I don't know what type of antifreeze was in my 9 when I bought the bike used(probably whatever was in it from the factory since it had 4,000 miles on it) but just before I had the mechanical seal replaced,I drained and replaced with Amsoil antifreeze(silicate/phosphate free) and refilled with fresh Amsoil antifreeze when the seal was replaced
 

·
Registered
Joined
·
18 Posts
Anyone looking to add a SPECTACULAR luggage rack to the Vaquero...look no further than Custom World International.
http://www.cw-intl.com/Pubvaquero/vaquero en.htm
I just bought and installed and it is a solid beautiful piece if you are looking to increase the luggage platform for the Vaquero.
No..I am not a dealer, but anyone who owns a Vaquero should consider this rack. It blew me away!
 

·
BOTM Winner, December 2013
Joined
·
1,172 Posts
Anyone looking to add a SPECTACULAR luggage rack to the Vaquero...look no further than Custom World International.
http://www.cw-intl.com/Pubvaquero/vaquero en.htm
I just bought and installed and it is a solid beautiful piece if you are looking to increase the luggage platform for the Vaquero.
No..I am not a dealer, but anyone who owns a Vaquero should consider this rack. It blew me away!
and what exactly does this have to do with an antifreeze leak on a vn900 ?
 
1 - 13 of 13 Posts
Top