Kawasaki Vulcan Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
O.K. been riding since 1959 and have had everything going and some no longer going so I know all bikes have their own 'quirks'. I need to downsize from my C-90 at my age(knees are shot, back spasms etc). Really like the looks and feel of the 900. But one of main reasons not to go Suzuki again is their p*ssy electrical system. Replacing R/R and/or stator every
20 to 30 thousand miles is getting old. I know the early 900 had a stator problem but I've been told that '09 and up it was cured. True?? What else is needed to be done to correct a potential problem that has come up over the years? I like to do replacements/corrections over the Winter and ride with peace of mind. Well, you know......LOL. Thanks.
 

·
Registered
Joined
·
1,268 Posts
Stator seems to be the only real issue. The gas gauge isn't too accurate. Apparently, the Speedo is off too, but I haven't noticed on my 07 custom. If the seat is stock, start shopping. Some complain about the [email protected] highway speeds, but this engine is designed to spin faster than a big block V twin.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks. Gas guage and speedo's seem to be all bikes problem. Nothing big. Actually I have found some stock seats O.K. If it is that bad I'll probably get a Saddleman or strip and gel the stock. As for the H'way buzziness A different pulley should fix that or..........slow down. LOL Any problems with belt 'chirp'?
 

·
Registered
Joined
·
33 Posts
Ive got an 09 classic and...knock on wood... it as been a great bike so far. I checked out my speedo and gas guage shortly after joining the forum and seeing the issue with others, but mine seems to be be pretty spot on. But I do generally make it a habit to reset my trip when i fill up and I know I don't even have to think about gas for 200 miles. Safer than trusting the guage.

I have not had any issues with belt chirp either. Don't get me wrong, my 9 is full of little wierd periodic sounds and feels, but I guess they all do.

I have added some mods to mine, but really the only thing I HAD to do was take care of the stock seat issue. I think the stocker looks really good, and it even felt okay for the first 20 minuutes or so, but after that I started wiggling around.
 

·
Registered
Joined
·
415 Posts
I have a 2012,there are whirls and groans now and again like has been said, she purrs at 60-65mph, ngk makes iridium plugs for her, they come with standard, i find the new plugs a must have, also like the sheepskin buttpad from alaskan leather.com, does the trick for cheap, a blinker will beat fast sometimes, take it out and blow inside, problem solved. The more i ride it, she just may be a keeper. Kuryakyn makes a helmet lock, get the larger size, i've attached to highway bar(cobra) next to brake pedal, helmet sits on it nicely and attaches to lock. The weight of the 9 is just right too.....ride on....
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Ive got an 09 classic and...knock on wood... it as been a great bike so far. I checked out my speedo and gas guage shortly after joining the forum and seeing the issue with others, but mine seems to be be pretty spot on. But I do generally make it a habit to reset my trip when i fill up and I know I don't even have to think about gas for 200 miles. Safer than trusting the guage.

I have not had any issues with belt chirp either. Don't get me wrong, my 9 is full of little wierd periodic sounds and feels, but I guess they all do.

I have added some mods to mine, but really the only thing I HAD to do was take care of the stock seat issue. I think the stocker looks really good, and it even felt okay for the first 20 minuutes or so, but after that I started wiggling around.
200 miles....that is not too shabby at all. Thanks
 

·
Registered
Joined
·
242 Posts
20K+ miles with no problems at all with mine. Set to factory specs and no squeak from the belt at all; quiet as can be. Good cruise range before fill ups. No stator issues as yet. Bike has a nice low CG; feels lighter than it is. Very reliable. You can't go wrong with this bike.
 

·
Registered
Joined
·
214 Posts
Had my 07 Custom for 2 weeks now. Did not spend much time riding the first week while I was cleaning up the bike and fixing few small things - new throttle cables, plugs, wind screen, oil and coolant change and brakes and new headlight bucket.
I changed grips pegs, and pedal covers (old ones were not taken care of). Went out on the weekend for a 130 km ride most 60 to 90km and was out for a few hours. The seat was great compared to the one on my 500, I do want to get a Solo seat not sure which one. I have change the grips to ISo and still had a little buzzing in my fingers after 45 mins or so.

There are definitely different noises than my 500 but I love this bike. Beautifully balanced and does not really "feel" any heavier than the baby Vulcan. Handles cross winds much better and at speed 90to 100 km feels very stable. Still need to finish up a couple of things and have to add my sound system and electrical outlet. This could be my last bike!
 
1 - 11 of 11 Posts
Top