Kawasaki Vulcan Forum banner

21 - 26 of 26 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #21
Or can I completely bypass this fuel evaporative system somehow completely since it just seems to be causing the bike issues (thanks CA) I mean would that hose having a slit in it even be able to cause the bike to bog down at all?
 

·
Registered
Joined
·
1,713 Posts
I can't answer your question, but what I would do at this point is take the hose to an auto parts dealer. Them its from your evap system and see what they recommend to use as a replacement. You won't have the nice, neat bend Kawi puts in it, but you should be able to get it work.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #23
I can't answer your question, but what I would do at this point is take the hose to an auto parts dealer. Them its from your evap system and see what they recommend to use as a replacement. You won't have the nice, neat bend Kawi puts in it, but you should be able to get it work.
Thanks yeah I'll give that a go, might as well replace the part. I was reading more into it and it's some crud that CA requires but doesn't look like it should effect the bikes performance (at least that specific hose) I have vinager in the tank right now and will be letting that sit and swish for a few days then will get it all cleaned out and completely dried I also ordered some "Quantum Kawasaki T35 Fuel Pump Strainer Only Vulcan 900 Custom" to replace in the fuel pump but those will take a few weeks it looks like to get in. Will keep updated on the progress.
 

·
Super Moderator
Joined
·
3,306 Posts
Can’t you use some regular fuel line. Assuming you have the room. Measure the inner diameter and get a longer piece to make up for the 90 degree in the factory hose.
 

·
Registered
Joined
·
8 Posts
Thanks yeah I'll give that a go, might as well replace the part. I was reading more into it and it's some crud that CA requires but doesn't look like it should effect the bikes performance (at least that specific hose) I have vinager in the tank right now and will be letting that sit and swish for a few days then will get it all cleaned out and completely dried I also ordered some "Quantum Kawasaki T35 Fuel Pump Strainer Only Vulcan 900 Custom" to replace in the fuel pump but those will take a few weeks it looks like to get in. Will keep updated on the progress.
Did you get it fixed? Let me know what you did to get it running, i'm having the exact same issue. As soon as I give it half throttle it cuts out and bogs down.
 
21 - 26 of 26 Posts
Top