Kawasaki Vulcan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I have a Vulcan 1700 Classic that i have installed a cobra fi2000 and a set of
cobra speedster longs. The bike runs great other that the popping on deceleration. I have tried everything, the exhaust has no leaks. I have checked it numerous times and i have also installed new header gaskets twice and are sealing fine. I have also plugged the fresh air hose for the AIR system in the right side air cleaner box and that also hasnt helped much. I have tried adjusting the fi2000 up in down in different increments and havent seemed to found a spot that is right either. When i adjust the fuel up on idle and cruise it gets worse and when i adjust it all the way down its also seems to pop pretty bad. I am out of ideas and if anyone can help i would greatly appreciate it. Thanks.
 

·
Registered
Joined
·
113 Posts
My 2009 Voyager did the same ....... ECU was changed up for a new one, and the popping has gone away
 

·
Registered
Joined
·
34 Posts
I have a 2011 VV without any mods factory pipes im guessing ECU was set to optimal factory settings .Sience day one the bike was poping on decel .I questioned that at the dealer during my 600 mile service .They took a test ride and called mamasaki their anwser was it all normal they wanted the bike to sound like that ,ads a character to the bike .Its horse poo in my opinion. But they dont want to do anything about it.
Another problem i have is noise on acceleration when bike is cold.When i let it warm up to middle line its fine otherwise its clonking little for 2-3 miles .I 'v noticed some people had expirienced same problem on this forum. Using 93 gas and oil is in the middle betwen the gauge lines.Other than that its a great bike.Loving avery mile per smile on it:). even if its burning more gas than some of us expecting of it. Traded up from 900 classic .
My wife is loving the smooth ride that this one provides.
One more issue the seat is a pain in my tail bone after an hour of riding .Need to take break for 5 min and i can go for another hour .Thinking about gel seat .Any one found some improovement going with that?For now i just use my car pillow under my sensitive rear end.:)
 

·
Registered
Joined
·
369 Posts
I have a Vulcan 1700 Classic that i have installed a cobra fi2000 and a set of
cobra speedster longs. The bike runs great other that the popping on deceleration. I have tried everything, the exhaust has no leaks. I have checked it numerous times and i have also installed new header gaskets twice and are sealing fine. I have also plugged the fresh air hose for the AIR system in the right side air cleaner box and that also hasnt helped much. I have tried adjusting the fi2000 up in down in different increments and havent seemed to found a spot that is right either. When i adjust the fuel up on idle and cruise it gets worse and when i adjust it all the way down its also seems to pop pretty bad. I am out of ideas and if anyone can help i would greatly appreciate it. Thanks.
ive got tri ovals and the same fuel processor you have and i get poping as well, i used to think my gaskets were leaking as well. i dont think theres much we can do about the popping, ive got mine set at 3-3-0 that seems like the best
 

·
Premium Member
Joined
·
2,115 Posts
I have a 2011 VV without any mods factory pipes im guessing ECU was set to optimal factory settings .Sience day one the bike was poping on decel .I questioned that at the dealer during my 600 mile service .They took a test ride and called mamasaki their anwser was it all normal they wanted the bike to sound like that ,ads a character to the bike .Its horse poo in my opinion. But they dont want to do anything about it.
Another problem i have is noise on acceleration when bike is cold.When i let it warm up to middle line its fine otherwise its clonking little for 2-3 miles .I 'v noticed some people had expirienced same problem on this forum. Using 93 gas and oil is in the middle betwen the gauge lines.Other than that its a great bike.Loving avery mile per smile on it:). even if its burning more gas than some of us expecting of it. Traded up from 900 classic .
My wife is loving the smooth ride that this one provides.
One more issue the seat is a pain in my tail bone after an hour of riding .Need to take break for 5 min and i can go for another hour .Thinking about gel seat .Any one found some improovement going with that?For now i just use my car pillow under my sensitive rear end.:)
As far as your tail bone I have a suggestion. You might want to try what I'm using. It's an "Air Hawk 2" seat cushion. Check it out at this web sight and you can get it cheaper if you google it. I use the medium size.
http://www.airhawkseatcushions.net/c-7-airhawk-motorcycle-cushions.aspx?&pagesize=999999&gclid=CKCe8IDtsaoCFQsS2godT0-u_Q

BTW I have the gel seat and don't use it because it raises me up 2 more inches.:mad:
 
1 - 6 of 6 Posts
Top